Hello Guest it is December 06, 2019, 05:34:13 PM

Author Topic: Connection issues with 57CNCdb25  (Read 3926 times)

0 Members and 1 Guest are viewing this topic.

Connection issues with 57CNCdb25
« on: May 20, 2016, 11:36:00 AM »
Hi,

I'm a complete CNC newbie, so I'm probably missing something basic...  at any rate here's my setup:

CNC Router Parts PRO4824
Mach 4 v. 4.2.0.2914
Pokeys Mach4Plugin v. 8.01.0.3017
Pokeys 57CNCdb25 v. 4.1.64
Gecko G540 rev. 8

So far have not been able to get any reliable connection on my machine - and no motion either.

Keep getting loads of "Connection with the device lost" - "Connection re-established" - "Error while configuring pulse engine - pulse engine not enabled" - "E-Stop Condition" - "E-Stop Cleared!"  (The e-stop is currently jumpered on the gecko - and I have a green light on the gecko, so I don't think there is any issue there...)

Adding to all the headache is that then it loses my motor configurations every so often...

I saw that the Pokeys Mach4 plugin was built for Mach 4 version .3017 - but all I can find on the Mach website is version .2914 - don't know if that is the heart of the issue or not...

Any help would be appreciated.

Thanks,

Mark


Offline NeoTO

*
  •  504 504
    • View Profile
    • PoLabs
Re: Connection issues with 57CNCdb25
« Reply #1 on: May 20, 2016, 02:10:36 PM »
Hi, Mark

If you have your PoKeys57CNCdb25 connected to your router, disconnect it first. Do you still get the 'connection lost' problems when starting and configuring Mach4?
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope
Re: Connection issues with 57CNCdb25
« Reply #2 on: May 20, 2016, 02:43:31 PM »
With the PoKeys57CNCdb25 disconnected, all I get are the E-Stop messages.  I tried this several times to verify.

I then plugged it back into the G540 (with all motors unplugged) and tried again (starting and configuring) - again, all was well except for the E-Stop messages.

Then I plugged in - only the X motor - and started Mach...  this time I got a steady stream of disconnect and pulse engine messages.

Thanks,

Mark

Offline NeoTO

*
  •  504 504
    • View Profile
    • PoLabs
Re: Connection issues with 57CNCdb25
« Reply #3 on: May 20, 2016, 03:23:06 PM »
What pin did you select as E-stop input?

The disconnect events are usually caused by large current flowing from/to CNC motor drivers to PC via USB. This can be due to improper power supply grounding. What power supply do you use? How do you have the grounds connected?

Can you post a picture of your machine setup?
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope
Re: Connection issues with 57CNCdb25
« Reply #4 on: May 20, 2016, 04:11:33 PM »
Thanks for your help, NeoTO.

E-stop input is set to pin 10.

Power supply is a 48 v 12.5 a dc.  It is wired with three wires to a grounded wall outlet...  

As you can see in the picture - power setup is extremely simple at the moment.  G540 jumper is from pin 12 to pin 10 (per gecko manual)

Mark

« Last Edit: May 20, 2016, 04:16:09 PM by Mark Haley »

Offline NeoTO

*
  •  504 504
    • View Profile
    • PoLabs
Re: Connection issues with 57CNCdb25
« Reply #5 on: May 21, 2016, 03:22:56 AM »
Do you have the power supply and your computer connected to the same wall socket?

As I noted, the most probable cause for the problem is the current flowing through the PoKeys device (between the power supply and PC). It may seem unreasonable, but try rotating the power supply power plug by 180 degree.

Regarding E-stop: is this behaviour sporadic or constant?
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope
Success! Reliable motion on all axes.
« Reply #6 on: May 21, 2016, 08:57:26 AM »
Your question regarding the e-stop got me to thinking that there might be a setting that was incorrect - so taking a shot in the dark, I switched the e-stop input to "Active Low" and then everything started to work.

Yay!

So, first baby steps taken - onward!   :)

Thanks so much for your questions and suggestions.

Mark