Hello Guest it is December 11, 2019, 11:45:23 AM

Author Topic: MACH4, ESS, C25 smoth stepper terminal board V3.1, AND BL-TB6600-V1.2 problem  (Read 7053 times)

0 Members and 1 Guest are viewing this topic.

please i need your help

 I'm building small CNC router and trying to run the motors before start building the machine

my hardware as follow:
-  ESS- Ethernet_Smoothstepper
- C25 smoth stepper terminal board V3.1,
-  BL-TB6600-V1.2, stepper motor driver module
- 3 stepper motor 1.5A, NEMA17, KL17H248-15-4A
- Power supply 24VDC, 10A

i'm using Mach4 demo version. i have connected the hardware and configured Mach4 and ESS for 2 motors only  

I start using G-code file which include in Mach4 but there is no action happen in the motors

 attached hardware connection and configuration

Offline dude1

*
  •  1,253 1,253
    • View Profile
you need a E stop to start with ESS needs it

Offline Tweakie.CNC

*
  • *
  •  8,021 8,021
  • Super Kitty
    • View Profile
    • Tweakie.CNC
I hope you don't mind a suggestion but just an observation regarding wiring...

When you come to wiring-up the actual machine, it would be best if you don't 'daisy-chain' the power connections to your stepper drivers (each driver should be wired directly back to the PSU terminals).

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Armature,
I can not tell from the picture but the C25 board actually needs power, and it can be down two different ways.   If you move the jumps on the ESS to allow the power to flow through P1 and P2 then the C25 does get the required power, you can verify by using a meter between the Ground Terminals and the 5V terminal on the C25 board.  If you forgot to adjust the ESS jumpers to allow that power to flow the motors will not move.  Blockhead also mentioned you need to define the ESTOP, for testing you can just use a wire jumper from ground to the ESTOP pin, i defined mine as P15, you had to declare this inside of MACH4 under inputs.  The second way to provide 5V power to the C25 board is to run the power directly into the GND and 5V terminals.

Russ

Offline DazTheGas

*
  •  750 750
  • DazTheGas
    • View Profile
Mach4 or ESS does not require an estop configured to function, i dont have one configured myself, my estop is between 24v - tokill all motors regardless of what mach4 says.
The c25 can be powered from the ESS but then you have to remember what current you draw through the c25 comes from the ESS.
I have never yet connected the enable pins on a driver yet they seem to be ok without it.

with this I would look at first makin sure the c25 has power and trying without the enable wires connected.

DazTheGas
Theres always time for a choccy biccy

Offline dude1

*
  •  1,253 1,253
    • View Profile
Daz haveing a kill power on the stepper power can blow your stepper drivers it needs to be on the control enable disable.

also some BOBS need a Estop and a some stepper driver require a enable

all mine do

Offline DazTheGas

*
  •  750 750
  • DazTheGas
    • View Profile
Sorry didnt sound right, my estop is on the neutral 230v so hitting estop discharges the 24v psu.

Quote
BOBS need a Estop and a some stepper driver require a enable
yes suppose I was just thinkin of my own setup, however the c25 has no mention of needin estop to run.

Double checked the TB6600HG ic and your right it does req a high signal to enable the driver ;-)

DazTheGas
Theres always time for a choccy biccy

Offline dude1

*
  •  1,253 1,253
    • View Profile
that's better Daz its something that surprised me, I did not think you put it correct, and the TB6600HG ic can be 50/50 depending on who made them, armature they may be Dead if the C25 enable does not get them going if the C25 only needs a enable, I will look at the manual my self
I have tried to active E-stop but still same problem
but i think i got the reason but i don't know how can i solved
there is no 5V coming from port#1 in C25 terminal board to supply the stepper drive board (Tb6600)
once i supply 5V to the stepper drive board (Tb6600) from ESS the motor running.
So please How can active this 5V in port#1 in C25 terminal board?

Offline DazTheGas

*
  •  750 750
  • DazTheGas
    • View Profile
You need JP2 enabled on the ESS

DazTheGas
Theres always time for a choccy biccy