Hello Guest it is May 22, 2019, 01:48:01 PM

Author Topic: Display Mode Button - Not Working?  (Read 1609 times)

0 Members and 1 Guest are viewing this topic.

Offline Davek0974

*
  •  2,495 2,495
    • View Profile
    • DD Metal Products Ltd
Display Mode Button - Not Working?
« on: January 15, 2016, 06:51:37 AM »
Could there be a reason why my display mode button does nothing?
It has this VB code in it ...

value = GetParam("Boundry")
if  value = 1 then
SetButtonText " Job "
SetParam "Boundry" , 0
 else
SetParam "Boundry" , 1
SetButtonText "Machine"
end if

So I am going out on a limb here and guessing the button text should change when pressed but mine always says "display mode" and seems tot do bugger all.

Just wondering :)

Also, is there a zoom-to-fit option anywhere??
« Last Edit: January 15, 2016, 06:54:06 AM by Davek0974 »
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives

Offline ger21

*
  • *
  •  6,233 6,233
    • View Profile
    • The CNC Woodworker
Re: Display Mode Button - Not Working?
« Reply #1 on: January 15, 2016, 07:52:47 AM »
Quote
Also, is there a zoom-to-fit option anywhere??

Don't have a copy of Mach3 here, but try double clicking in the toolpath window.

No idea about the other issue.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Davek0974

*
  •  2,495 2,495
    • View Profile
    • DD Metal Products Ltd
Re: Display Mode Button - Not Working?
« Reply #2 on: January 15, 2016, 08:14:20 AM »
Double-Click in my window and it just resets any scrolling etc to standard view
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives

Offline ger21

*
  • *
  •  6,233 6,233
    • View Profile
    • The CNC Woodworker
Re: Display Mode Button - Not Working?
« Reply #3 on: January 15, 2016, 08:17:59 AM »
It fit's the entire toolpath into the window. If your g-code has commands that send it far away from your part, those are included.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Davek0974

*
  •  2,495 2,495
    • View Profile
    • DD Metal Products Ltd
Re: Display Mode Button - Not Working?
« Reply #4 on: January 15, 2016, 08:24:59 AM »
Not working I don't think then, It does change the cross-hairs at 0/0 to dashed lines but that seems to be all it does, I think the text does not change as this screen-set uses button graphics and not plain buttons.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives

Offline ger21

*
  • *
  •  6,233 6,233
    • View Profile
    • The CNC Woodworker
Re: Display Mode Button - Not Working?
« Reply #5 on: January 15, 2016, 08:27:14 AM »
Sounds like it is working then.
DO you have the correct values for your softlimits? That's what tells Mach3 what the table size is.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Davek0974

*
  •  2,495 2,495
    • View Profile
    • DD Metal Products Ltd
Re: Display Mode Button - Not Working?
« Reply #6 on: January 15, 2016, 08:28:14 AM »
Fixed it !

You have to press "Regen Path" after pressing the display mode button, I have added DoOEMButton(160)'Regen Path to the display mode button now and it all looks better, the text will not change but hey-ho ;)
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives