Hello Guest it is December 15, 2019, 06:57:26 PM

Author Topic: Disabling arrow keys for jogging when editing MDI  (Read 3705 times)

0 Members and 1 Guest are viewing this topic.

Disabling arrow keys for jogging when editing MDI
« on: December 22, 2015, 01:23:30 PM »
I like using the keyboard arrow keys for jogging.  But when I want to edit something in the MDI window, the arrow keys continue to jog instead of moving me around the text.  I thought that in Mach 3, when MDI editing, the arrow keys stopped jogging.

Aside from choosing other keys for jogging, is there a way to prevent the arrow keys from jogging while editing in the MDI window?

Offline Chaoticone

*
  • *
  •  5,634 5,634
  • Precision Chaos
    • View Profile
Re: Disabling arrow keys for jogging when editing MDI
« Reply #1 on: December 22, 2015, 03:18:53 PM »
At some point we may be able to do it in the Keyboard inputs enable/disable button but for now you can disable and enable it in the taskbar. You can click on the CNC Keyboard functions icon (looks like a keyboard) and disable/enable it.
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline Pedio

*
  •  200 200
    • View Profile
Re: Disabling arrow keys for jogging when editing MDI
« Reply #2 on: December 22, 2015, 06:32:45 PM »
My version remembers this setting. I have disabled it.
Re: Disabling arrow keys for jogging when editing MDI
« Reply #3 on: December 22, 2015, 06:54:16 PM »
A workaround for this issue might be to re-configure the keyboard plug-in
so that all the jog functions require Shift, Alt, or Ctrl to be held down.
My choice would be to change the defaults so that Incremental jogs
require Alt and normal continuous jogs require the Ctrl which is just to
the left of the arrow keys on most keyboards. Rapid jog would still use
the Shift key.

You can access the keycode settings by using CONFIG > PLUG-INS and select
the keyboard plug-in.
Steve Stallings
www.PMDX.com
For PMDX product support, please use PMDX forum or direct email for quickest response. We do not use this forum as our primary product support site.

Offline Pedio

*
  •  200 200
    • View Profile
Re: Disabling arrow keys for jogging when editing MDI
« Reply #4 on: December 22, 2015, 08:39:21 PM »
I like Steve's suggestion if you want keyboard control. I have the Shuttle Pro as a pendant. It works GREAT!!!!!

Offline Chaoticone

*
  • *
  •  5,634 5,634
  • Precision Chaos
    • View Profile
Re: Disabling arrow keys for jogging when editing MDI
« Reply #5 on: December 23, 2015, 11:19:20 AM »
I like Steve's suggestion if you want keyboard control. I have the Shuttle Pro as a pendant. It works GREAT!!!!!

Definitely worth considering. Anyone else want to weigh in? Feel free to.
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline DazTheGas

*
  •  750 750
  • DazTheGas
    • View Profile
Re: Disabling arrow keys for jogging when editing MDI
« Reply #6 on: December 23, 2015, 05:14:19 PM »
Well I did think of doing something on these lines in the plc but the keys are then dead so its obviously disabling the motion and not the plugin.

Code: [Select]
    local tab, rc = scr.GetProperty("MainTabs", "Current Tab")
    local tabG_Mdione, rc = scr.GetProperty("nbGCodeMDI1", "Current Tab")
    local iReg = mc.mcIoGetHandle (0, "Keyboard/EnableKeyboardJog")
    if ((tonumber(tab) == 0 and tonumber(tabG_Mdione) == 1)) then
    mc.mcIoSetState(iReg, 0);
    else
    mc.mcIoSetState(iReg, 1);
    end

It would be easy to implement in the keyboard plugin using the new api command mcRegSendCommand this could send a command to disable the plugin whilst the mdi has focus instead of disabling it via the taskbar.

But failing that then Steves idea is prob the bets solution

Daz
Theres always time for a choccy biccy
Re: Disabling arrow keys for jogging when editing MDI
« Reply #7 on: October 08, 2016, 06:52:02 PM »
These workarounds don't seem to change the behavior of Mach capturing ALL the arrow keys strokes whether Mach is the Windows foreground program or not.  I would like my arrow keys to work when I'm using a a separate editor program outside of Mach, but if Mach is running, arrow keys don't work in any other running program.  Mach should only consume keystrokes if it is the foreground program.  How do I get Mach to play nicely with other programs like editors?

Thanks.

Offline DazTheGas

*
  •  750 750
  • DazTheGas
    • View Profile
Re: Disabling arrow keys for jogging when editing MDI
« Reply #8 on: October 09, 2016, 02:23:16 AM »
Not sure if this may help  http://www.machsupport.com/forum/index.php/topic,33270

DazTheGas
Theres always time for a choccy biccy
Re: Disabling arrow keys for jogging when editing MDI
« Reply #9 on: November 22, 2016, 01:05:40 AM »
Yes! - thanks a lot.  That helps for editing from within Mach4.  That's a big help.  Is there a place I can place those same scripts to activate and deactivate the keyboard plugin when Mach comes and goes from being the program-of-focus in the foreground of Windows?