Hello Guest it is March 06, 2021, 09:41:06 AM

Author Topic: Cap04 Plasma THC  (Read 6275 times)

0 Members and 1 Guest are viewing this topic.

Re: Cap04 Plasma THC
« Reply #10 on: December 22, 2015, 11:57:13 AM »
Ok, copied and changed the M3, loaded the right screen set, and still can't reset to be able to "home" or jog or anything.
The machine is still locked because of the "Down" signal from the Cap04. Getting a bit fustrated here.
Re: Cap04 Plasma THC
« Reply #11 on: December 22, 2015, 12:10:24 PM »
Can you post or email your XML file please.

You will need to call or rename it something unique like iphillips.xml
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”

Offline BR549

*
  •  6,944 6,944
    • View Profile
Re: Cap04 Plasma THC
« Reply #12 on: December 22, 2015, 12:17:31 PM »
What do you mean by Locked ???  The down signal should not lock the machine up  . Do you mean the reset button will not reset ??

You have something not configured correctly . Start over and double check every one thing at a time. DO NOT assume anything, double check it all.

The THC should ONLY be active when it is turned on from the M3 and turned off from the M5 ???

I would completely disconnect the THC and get the machine working, it will run just fine without a THC .  Then when you have it all running correctly then hook it back up and tune it in.

(;-) TP
Re: Cap04 Plasma THC
« Reply #13 on: December 22, 2015, 12:54:52 PM »
Yes, the Reset won't.
I am going to go through it all again just to be sure.
TP-
If you look back, everything does work. It's only when I plug the THC box for the sensor, that the unit won't reset.
Re: Cap04 Plasma THC
« Reply #14 on: December 22, 2015, 01:52:38 PM »
Here's the xml
Re: Cap04 Plasma THC
« Reply #15 on: December 23, 2015, 03:08:29 AM »
Mach3 >>> Config >>> ports & pins >>> mill options tab
 
unselect:
Allow THC even when not in THC >>> disable this for a start, enable your THC via mcode
g28.1 no initial move  >>>> not sure about why you set this (I dont use it)
set OUTPUT5 when in THC >>> you have not set output 5 (what would you use this for)?


Mach3 >>> Config >>> General Config
Change the lookahead to 200

___________________________________


Also check the port addresses are correct and align with the actual addresses assigned on your machine.


I cannot see anything that will not allow your machine to reset specifically.

Rob
 
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”
Re: Cap04 Plasma THC
« Reply #16 on: January 07, 2016, 12:29:30 PM »
Hi Rob,

Just wanted to get back to you.

So, once I changed the notes above it would allow me to reset! Thanks!

I am now trying to run it without actually cutting but sensing a plate I have to be sure the sensor is doing what it should.
Thanks again.
Ian
Re: Cap04 Plasma THC
« Reply #17 on: January 07, 2016, 12:43:52 PM »
I'd suggest adding a few LEDs to the screenset to show you the up and down motion plus the THC OK.

Can't remember if they are on the standard screenset but I can walk you through that if you want
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”
Re: Cap04 Plasma THC
« Reply #18 on: January 07, 2016, 01:46:25 PM »
Yah, they have Up,Down, and Probe. Included a screen shot
I think the problem I'm having now is the probe isn't feeding back or being delt with. It just drives into the plate.
I can see the Up and In Postion LEDs on the unit but no opposite action to pull the Z back and start the file.

Maybe the M3 part of the process didn't take?

Re: Cap04 Plasma THC
« Reply #19 on: January 07, 2016, 03:18:46 PM »
Where did you place the m3 macro?

Can you go to its location and copy and paste from the windows explorer bar the folder location.

Just check there is only one m3 macro in there (as you have added a second or replaced the first one more correctly)

I'll have a look at the macro later for you
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”