Hello Guest it is July 18, 2019, 03:36:50 AM

Author Topic: Steppers and machine sounds bad, but not when rotating the toolpath  (Read 4407 times)

0 Members and 1 Guest are viewing this topic.

Hi all,

I came across an odd problem with my machine today. When I'm both running some Gcode or jogging, the steppers sound a bit dodgy and it causes the whole machine to vibrate and make a high pitch almost frictiony sound. However as soon as I rotate the toolpath it stops and the steppers and machine sound very smooth and happy again.

Has anyone got any ideas on what could be causing this?

(Also this happens at whatever maximum speed I set for the motors in motor tuning)

Thanks,
Andy

Machine details:
2.2Nm Nema23 steppers. Drivers set to 5 mircosteps
Running Mach3 on
Windows XP, Intel Pentium 3Ghz, 2GB RAM
Re: Steppers and machine sounds bad, but not when rotating the toolpath
« Reply #1 on: November 26, 2015, 02:42:48 PM »
can you post your xml file, you will need to call it something unique like andythepandy93.xml...
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”
Re: Steppers and machine sounds bad, but not when rotating the toolpath
« Reply #2 on: November 26, 2015, 02:52:40 PM »
Sure, I'm pretty new to all this so don't be too surprised if there's a stupid mistake in there... ;D

Also forgot to say, using the 2010 screenset

Thanks
Re: Steppers and machine sounds bad, but not when rotating the toolpath
« Reply #3 on: November 26, 2015, 06:23:40 PM »
Couple of questions (probably not creating your issue... but worth a consideration / change or curious question....)

Config >>> Ports & Pins >>> Inputs tab....

Why have yo got Limits Over-Ride input enabled... without a pin ref, with a hotkey
(what are you trying to do as there may be another way?)

Config >>> Ports & Pins >>>Spindle Setup tab (Left Hand column)

Why have you got the CW spindle setup as Output 2.... and CCW spindle as Output 1..... but ou have defined only one spindle output?

Config >>> Motor Tuning >>> All Axis

Why have you set the acceleration at 150mm/s/sec .... and the limiting velocity at 1000mm/s/min (16.667mm/s)
Have you tried to lower the acceleration ... maybe say start at something like 50mm/s/s and then increase the machine speed up to 3000mm/min (50mm/sec)

You are running 5mm pitch ballscrews I presume?   depending upon your setup voltage it can "probably" handle 50mm/sec max velocity..... but that acceleration seems a little quick to me (but I don't know your setup enough! [moving mass / weight etc of gantry]).

Config >>> General Config >>>

change the lookahead to 200 (2nd column from left)
un-check the watchdog checkbox  (1st column from left)
I would suggest changing your job increments (given your max resolution at 200 steps / mm = 1/200 or 0.005mm/step... hence something like
10, 5, 1, 0.5, 0.1. would probably be more workable (or whatever else you choose... all your choice!)

I would suggest checking a few of the checkboxes within the Right hand "Pgm End, M30 or Rewind Box"

(personal preference this one) I would suggest changing the initialisation string (centre top of tab / screen) to something like "G80, F50" and checking the checkbox to enabled the initialisation string on all resets.... the reasoning being is the "F50" will set the feedrate to 50mm/sec... and not the Mach3 std.....   note the one consequence of this is if you try to restart a gcode it will have reset the feedrate to the G0 feedrate..... (but your jog will work quicker....)


What voltage are you running your stepper drivers at?

Rob


Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”
Re: Steppers and machine sounds bad, but not when rotating the toolpath
« Reply #4 on: November 27, 2015, 10:55:15 AM »
Rob,

Thanks for such a detailed reply.

Quote
Why have yo got Limits Over-Ride input enabled... without a pin ref, with a hotkey
(what are you trying to do as there may be another way?)

My understanding of the limit override is that when the machine hits the limit switch (embarrassingly happens a lot at the moment!) when you press this switch it will disable teh limit switches so you can jog the machine back (is this correct?). I don't have a physical switch to do this so I have assigned the key next to the number 1 key to do this job instead.


Quote
Why have you got the CW spindle setup as Output 2.... and CCW spindle as Output 1..... but ou have defined only one spindle output?

I do not use spindle relays as I have a VFD which is controlled over serial. I believe I need the 'Disable Spindle Relays' tickbox unchecked though for my spindle to work. I don't recall changing the Output #'s for the CW and CCW.

Quote
Why have you set the acceleration at 150mm/s/sec .... and the limiting velocity at 1000mm/s/min (16.667mm/s)
Have you tried to lower the acceleration ... maybe say start at something like 50mm/s/s and then increase the machine speed up to 3000mm/min (50mm/sec)

You are running 5mm pitch ballscrews I presume?   depending upon your setup voltage it can "probably" handle 50mm/sec max velocity..... but that acceleration seems a little quick to me (but I don't know your setup enough! [moving mass / weight etc of gantry]).

That is a very good question. I guess I was stupidly plugging in numbers and not really thinking about their actual meaning. Yes it's a 5mm pitch ballscrew. I'll try the numbers you suggest now

Quote
change the lookahead to 200 (2nd column from left)
un-check the watchdog checkbox  (1st column from left)
I would suggest changing your job increments (given your max resolution at 200 steps / mm = 1/200 or 0.005mm/step... hence something like
10, 5, 1, 0.5, 0.1. would probably be more workable (or whatever else you choose... all your choice!)

Okay will do, could you briefly explain what these settings do?

The drivers are up to 50v but I have a 36v power supply hooked up.

After changing all those and restarting it still sounds the same. It's weird because if I hadn't noticed that the problem went away when I rotated the toolpath display, I would totally be blaming the bearings as it really sounds like they're making graunching noises but as soon as I move the toolpath it sounds perfect...  ???

Many thanks
Re: Steppers and machine sounds bad, but not when rotating the toolpath
« Reply #5 on: November 27, 2015, 12:31:05 PM »
Have you been through the wiring to check its all wired up correctly?

What sort of power supply is it using (switched mode or transformer)... Some smps require a minimum current draw before they regulate corrrctly

What stepper drives are you using?

Do you have a model number for the stepper motors?
Are they correctly wired as 4, 6 or 8 wire steppers?

Is the peak current setting correct on the drives (not RMS!)

Is this via a PC or laptop (some laptops apparently don't output the correct TTL 5v signals on the parallel port)

Just guessing at what it may be now
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”
Re: Steppers and machine sounds bad, but not when rotating the toolpath
« Reply #6 on: November 27, 2015, 12:42:54 PM »
Switched mode PSU (found here https://www.cnc4you.co.uk/400W-PSU-36Volt-11Amp?search=400W36V%2F11A)

These stepper drivers: https://www.cnc4you.co.uk/Stepper-Motor-Driver-4.5A,-50V-CNC-Microstepping-CW5045?search=CW5045
Stepper motors are Nema23s 2.2Nm, wired up as 4 wire.

The drives have a 8 DIP switch which configures the current, half current or full current and microstepping. I have them set to 4.2A, full current, and 5 microsteps.

It's a PC.
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”
Re: Steppers and machine sounds bad, but not when rotating the toolpath
« Reply #8 on: November 27, 2015, 12:45:34 PM »
As for the wiring, I followed the guide provided by cnc4you and have checked and it matches that.

Didn't say but this happens on all three axes' steppers
Re: Steppers and machine sounds bad, but not when rotating the toolpath
« Reply #9 on: November 27, 2015, 12:50:51 PM »
Nothing wrong with their stuff (I have their steppers...)

Can I suggest trying them on half current setting

I'll be back... On a phone... Sorry drip feed
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”