Hello Guest it is August 18, 2019, 01:57:40 PM

Author Topic: Problem with z axis cut  (Read 3425 times)

0 Members and 1 Guest are viewing this topic.

Problem with z axis cut
« on: September 07, 2015, 04:29:54 PM »
I am having a problem with the z axis on my 6040 machine and am looking for some help if possible.

I have drawn up a simple 2d engraving in Aspire 4.5 and selected a 45 deg included angle engraving tool with a 0.2mm flat point.

The aspire has out put the code for me which when I run it show a flat depth maximum of 1mm in the code when running on Mach3, at no point does it show any deeper cut.

However, when I measure the actual cut, it is 1.72mm deep. the other 2 axis are the correct sizes. This depth of cut is constant throughout the design

I checked the calibration of the z axis, and it is correct as near as I can measure.

Any suggestion gratefully received.

On another tack, during a cut, there was a judder and the cut was displaced laterally by 40mm on the x axis at one point, it then continued on and completed the cut perfectly after, just 40mm offset. The tool returned to zero after the cut, which was also offset by 40mm on the x axis. The work piece had not moved and the travel of the spindle was unchanged, i.e. it had not slipped on the screw somehow.

Again bright ideas for a check and solution please !!

Offline Tweakie.CNC

*
  • *
  •  7,882 7,882
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Problem with z axis cut
« Reply #1 on: September 08, 2015, 01:58:55 AM »
Could you post your .xml file (rename it to a unique name ie. Ducman.xml) so we can try to find the cause of these two problems.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Problem with z axis cut
« Reply #2 on: September 08, 2015, 03:03:33 AM »
Ok many thanks for the swift response, .xml file attached as requested

Offline Tweakie.CNC

*
  • *
  •  7,882 7,882
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Problem with z axis cut
« Reply #3 on: September 08, 2015, 07:04:44 AM »
My recommendations…

Reduce your Kernel speed from 100kHz to 35000Hz (25000Hz may be even better).
Reduce your Velocity & Acceleration settings for your X and Y axes by approx. 30% from their current values.
Check your requirement for input signals (Config. / Port & Pins) – you are specifying pins 7,8,9 which are not allowed (these are output signals used in Motor Outputs).
Check your requirement for Output #1 as you are specifying pin 5 which is a duplicate of your Y axis Direction signal.
Uncheck Use WatchDogs in General Config.

Try that for starters and let us know how you get on.


Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Problem with z axis cut
« Reply #4 on: September 08, 2015, 07:32:01 AM »
Thanks very much for the feedback I will try what you suggest, The figures there are what came as the configuration file for the machine, I do not understand them so did not alter them.

I have done the first 2 items

However like I say, I do not understand what you have suggested, I am assuming the changes will not cause any problems ?

"Check your requirement for input signals (Config. / Port & Pins) – you are specifying pins 7,8,9 which are not allowed (these are output signals used in Motor Outputs)."
"Check your requirement for Output #1 as you are specifying pin 5 which is a duplicate of your Y axis Direction signal."

I have found these but now what do I do? change them to what?? like I say, sorry don't understand, surely all this stuff is preselected by manufacturer?? or is my ignorance just being highlighted again  :-[

Seriously, thanks for the help, but I need more cyber hand holding I am afraid

Offline Tweakie.CNC

*
  • *
  •  7,882 7,882
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Problem with z axis cut
« Reply #5 on: September 08, 2015, 08:02:21 AM »
Basically… the LPT parallel port, as far as Mach3 is concerned, has Input pins and Output pins (10-13 & 15 being Input pins and 1-9,14,16 & 17 being Output pins with pins 18-25 being Ground). Input pins cannot be used as Outputs and visa-versa.
Your equipment manufacturer should have an understanding of this and provide you with settings for Mach3 that are correct.

However, the world is not perfect so we make do…

I would disable the X,Y,Z Input Signals (specifying pins 7,8,9)
Also disable Output #1 (specifying pin 5)

Try it and see.

Tweakie.

(I have been using Mach3 for more than 10 years now and I am still learning  ;) )
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Problem with z axis cut
« Reply #6 on: September 08, 2015, 08:08:27 AM »
OK,thanks again   :D   this is a USB connected card not parallel  does that make a difference?

Offline Tweakie.CNC

*
  • *
  •  7,882 7,882
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Problem with z axis cut
« Reply #7 on: September 08, 2015, 08:13:21 AM »
OK,thanks again   :D   this is a USB connected card not parallel  does that make a difference?

It may well make a difference - which external motion controller are you using ??

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Problem with z axis cut
« Reply #8 on: September 08, 2015, 08:21:19 AM »
Xulifeng-Mach3-USB-Motion-Card

Offline Tweakie.CNC

*
  • *
  •  7,882 7,882
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Problem with z axis cut
« Reply #9 on: September 08, 2015, 09:13:01 AM »
The Xulifeng emulates the parallel port, using the same pin numbering for the inputs and outputs.

Which version of Mach3 are you using ??

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.