Hello Guest it is July 11, 2020, 05:42:39 PM

Author Topic: Machine gets wacky after tool change.  (Read 3588 times)

0 Members and 1 Guest are viewing this topic.

Machine gets wacky after tool change.
« on: July 24, 2015, 11:35:25 PM »
I got a new to me machine a week ago and been trying to work out the bugs.  Ive posted in here a few times and gotten some good info and getting things working. My new problem is after a tool change i hit the start button and the machine does not go where its supposed to go. It doesnt do it all the time. Some times it works fine some times i makes a complete left turn and goes in the oppiset direction and starts running the program. Im hoping its just a setting or a simple fix.

 Have you guys seen this before. Thanks for your help.

Offline Tweakie.CNC

*
  • *
  •  8,357 8,357
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Machine gets wacky after tool change.
« Reply #1 on: July 25, 2015, 08:21:40 AM »
Could you perhaps post your .xml file of the profile you are using for this machine ( rename it to something unique ie. Bhoh.xml ).

Tweakie.
KEEP SAFE !
Re: Machine gets wacky after tool change.
« Reply #2 on: July 26, 2015, 04:20:44 PM »
I dont know how to post my xml. Haha. Im not that  good with computers. If someone walks me through it i should be able to do it.

Offline Tweakie.CNC

*
  • *
  •  8,357 8,357
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Machine gets wacky after tool change.
« Reply #3 on: July 27, 2015, 02:38:41 AM »
I will try...

Bottom right of Mach screen is your Profile name.
In Mach3 folder locate the .xml file with your profile name (typically - Mach3Mill.xml).
Copy this file to the desktop and then rename it to Bhohbein.xml (a unique name)

When making your post choose Additional Options / Choose File - selecting Bhohbein.xml

That should do it.

Tweakie.
KEEP SAFE !
Re: Machine gets wacky after tool change.
« Reply #4 on: August 03, 2015, 12:43:21 PM »
Sorry it took so long I had to copy xml to a zip drive then bring my other computer inside to get on the internet to post it haha.  Its been doing ok except for yesterday I had to stop the program.  I hit pause feed button while I was cutting a circle.  When I hit start button instead of continuing the circle it turned about 90 degrees and continued on with the circle.  Thanks for taking a look
Re: Machine gets wacky after tool change.
« Reply #5 on: August 05, 2015, 04:30:03 PM »
Another problem just happened. Was running the machine wasnt touching anything and the wizard screen popped up and went to 4th axis wizard then wrote itself a program and loaded it in mach3. The program i was running dissaperedand the machine stopped. Do i have a gremlin in mach3. Should i redownload and install it.
Re: Machine gets wacky after tool change.
« Reply #6 on: August 07, 2015, 12:28:58 AM »
Today the jogging controls stopped working. I even tried useing jog controls on mach 3 and that didnt work. When i got them working the axis would move 1 inch at a time. The step mode was stuck on and could not turn it off. Had to close out of mach3 and restart to get it working normal again. Anyone everseen this before.

Offline Tweakie.CNC

*
  • *
  •  8,357 8,357
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Machine gets wacky after tool change.
« Reply #7 on: August 07, 2015, 02:25:59 AM »
I did not spot anything unusual in your .xml file so I am pretty sure it's not that which is causing your problems.

The unexpected and non-requested behavior mentioned in your last posts would suggest that a complete re-install of Mach3 should be done.
Make a back-up of your existing Mach3 folder (to preserve .xml settings, screen sets, macro's, etc.) before uninstalling & deleting Mach3. Then make a fresh install - I suggest version R3.043.056  (only because that's the version I use and there have been a number of reported problems with R3.043.066).

If that does not completely resolve the issues you are having then I would perhaps suspect a bad RAM memory chip ??

Tweakie.
KEEP SAFE !
Re: Machine gets wacky after tool change.
« Reply #8 on: August 07, 2015, 12:41:36 PM »
How do i install other versions of mach3. Is there a place on the mach 3 site to douwnload older versions.
Re: Machine gets wacky after tool change.
« Reply #9 on: August 07, 2015, 12:43:18 PM »
Did you see any settings in my xml that should be changed.