Author Topic: Mach 4 softlimits not working  (Read 1645 times)

0 Members and 1 Guest are viewing this topic.

Offline it*guy

  • Active Member
  • Posts: 12
    • View Profile
Mach 4 softlimits not working
« on: February 23, 2015, 04:03:32 AM »
So First I am new to the entire CNC Scene. So please forgive me if i miss anything along the way with information.
My problem is occurring when I have the machine softlimit button on, my machine passes right through the limits  ??? AND only moves in the + direction >:(. when I turn off the softlimits it returns to normal operation ???.
I am using Mach 4 Hobby version 2230 with the PMDX 422 smart BOB. both are up to date with latest firmware/software. I am wondering if I have something in the settings wrong i.e. missed on/off tick. This option is very much a possibility seeing I am new to the CNC scene. My machine is a custom built 6'x10', from scratch 8).

Offline dude1

  • Active Member
  • Posts: 1,253
    • View Profile
Re: Mach 4 softlimits not working
« Reply #1 on: February 23, 2015, 04:54:18 AM »
have you got soft limits ticked in M4 config

Offline it*guy

  • Active Member
  • Posts: 12
    • View Profile
Re: Mach 4 softlimits not working
« Reply #2 on: February 23, 2015, 09:24:48 AM »
I am away from the machine, but I will check in a little bit. Is there a way I can output all of my settings in mach4 for troubleshooting?
thanks!
V/R
Mike

Offline bob_at_pmdx

  • Active Member
  • Posts: 151
    • View Profile
Re: Mach 4 softlimits not working
« Reply #3 on: February 25, 2015, 03:39:55 PM »
This issue has been addressed in the PMDX support forums here:
http://www.pmdx.com/PMDX-Forums/index.php?topic=57.0

Bob
PMDX

Offline it*guy

  • Active Member
  • Posts: 12
    • View Profile
Re: Mach 4 softlimits not working
« Reply #4 on: February 28, 2015, 09:03:02 PM »
Thanks Bob,
I hadn't quite made my way back to this forum to clear that up!
Everything is working great now BTW!
Video soon to follow!