Hello Guest it is April 11, 2021, 06:58:59 PM

Author Topic: Leadshine EL5 ac servo troubles  (Read 15388 times)

0 Members and 1 Guest are viewing this topic.

Re: Leadshine EL5 ac servo troubles
« Reply #50 on: January 10, 2017, 04:42:24 AM »
Hi Johnny
My drive is marked L5-750, and Leadshine support confirm from the serial number that it does have analogue input/support. However because it was sold by an online (Aliexpress) trader rather than a registered Leadshine agent, they wont support it beyond this confirmation. I will contact the seller, but I don't have much hope they will help as they're primarily a vendor of second hand drives (though this one was new).

The symptom I am seeing is that the motor does not run when /SON is activated and an analogue control voltage applied.

To troubleshoot the fault, I have disconnected CN1 from the machine, and wired it in a simple test config as per the Trial Run config from the manual, and configured all the relevant drive parameters:

After lots of mucking around I finally put an oscilloscope onto the drive output to see was it was outputing. The waveforms I am seeing at the servo drive motor outputs look unusual (to me). They are:

1. With aux and main power to the drive, and /SON not activated, there is ~ 100V pk-pk waveforms present at the outputs (I assumed in this state there would be no output from the drive).

2. With aux and main power to the drive, and /SON activated, but analogue speed control turned down to zero, there is ~ >300V pk-pk waveforms present at the outputs. This could make sense in terms of applying holding torque to the motor, I'm just again surprised at the magnitude of the voltage.. I'd have thought holding torque would be a lot less than driving torque, so the output voltage would be commensurately lower, but I've not looked at drive output before, so am not really sure what 'good' should look like.

Adjusting the analogue speed control makes little difference to the waveforms (which matches the fact the motor doesn't move when the voltage changes).

After a few seconds, the drive errors with Error 100 (out of position), presumably because the encoder feedback is that the motor is not rotating.

The motor is a non-Leadshine 750W servo, with encoder fitted. The motor/encoder has worked successfully in a previous setup, ie:

- the motor rotates correctly (ie tested using a different servo drive)

- when I disconnect Power Terminal 2 from the drive and meter the U, V W motor connections, the motor phases measure correctly (about 5 ohms each, and all roughly the same)

- the encoder is wired correctly, as the servo drive reports no encoder errors, and when the E5-750 drive was initially connected to the CSMIO/A controller (ie encoder -> E5 -> CSMIO), when I manually rotated the servo motor, the CSMIO showed the encoder position changing correctly.

I've just ordered an RS232 cable to fit the drive, so hopefully when that arrives I can see what the Leadshine Protuner software thinks is happening, though again I'm not sure if it'll be much use.

Lots of head scratching going on..!

regards,
Andrew
Re: Leadshine EL5 ac servo troubles
« Reply #51 on: January 10, 2017, 03:07:48 PM »
Hi Andrew
I tried to send the configuration of my servodrive,
but it was not possible to send an isr.file here.
I´l try to send the protuner manual instead.
If I can get your mail adress I will attach the isr.file
Maybe it will help
[johnny.sch@get2net.dk]
« Last Edit: January 10, 2017, 03:22:02 PM by Johnny cnc »
Re: Leadshine EL5 ac servo troubles
« Reply #52 on: January 10, 2017, 03:18:08 PM »
Hi Andrew
Please send an email and I will attach my configuration,
maybe it could help you.
Importent: when you have made the testdrive connected rs232 to the Protuner
you have to disconnect and set parameter 0.01 to 1 manually on the drive.
Regards  Johnny
« Last Edit: January 10, 2017, 03:24:25 PM by Johnny cnc »
Re: Leadshine EL5 ac servo troubles
« Reply #53 on: January 15, 2017, 03:45:33 AM »
Thanks Johnny,
I've emailed you now at the address you posted above.. let me know if you don't receive it.

cheers,
Anderw