Hello Guest it is October 22, 2019, 09:21:45 PM

Author Topic: Newbie needs help with Mach3  (Read 1229 times)

0 Members and 1 Guest are viewing this topic.

Newbie needs help with Mach3
« on: January 29, 2015, 11:36:59 PM »
Hey All,

I'm very new to CnC and just getting the grips on the basics so far, i have a sherline model 2000 mini-mill cnc and so far have managed to setup it all up correctly in mach3 as far as the motors and the axis' configuration is concerned.
The problem i'm having is i do my Cam work in MeshCam and then load that in OpenScam to simulate which it shows exactly what i want. However when i load into mach3 with the g-code, the stock thats defined in the toolpath isn't showing the same as what i did in MeshCam and OpenScam.

I assign the stock in cam to x 160mm by y 86mm by z 18mm. this allows me to have a border around the outside edge to allow for clamping.
The machined item is 135 x 45 x 18mm.
However what it shows in mach3 toolpath screen is the Left Clamping Area and the Bottom Clamping Area, it removes the Top and Right Side Clamping Area, Im not too sure whats happening here.

First image is the Simulation with the stock area defined and a border all the way around. Second image shows the border area that is excluded.
http://i.imgur.com/RDvukpU.jpg
http://i.imgur.com/e9kMYWy.jpg

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Newbie needs help with Mach3
« Reply #1 on: February 02, 2015, 03:56:42 PM »
Sounds like all you are needing to do is set the work offset correctly. For example jog to where you want the X and Y zero position to be and then press the Zero buttons at the side of X and Y DROs, you can then Regenerate the toolpath view to see if it is what you want.
Hood