Hello Guest it is April 20, 2019, 12:55:46 PM

Author Topic: Limit switch reset problem  (Read 1390 times)

0 Members and 1 Guest are viewing this topic.

Limit switch reset problem
« on: January 03, 2015, 08:20:30 PM »
Hi
I am rewiring my cnc and have a problem with the limits. I grouped all the limits for the + and – limit direction for
the z and y together. Another set of limits are grouped for the + and – limit directions for the X.
The limits are snap action limits and they are set for active low. When I press the reset it shows that
M1 + and M1- are yellow
M3+ M3- and M3 Home are yellow
It seems when I try to set them for active high the software LED change from yellow to gray. Then I can
reset. But when I open Mach3 for a new session I get the same problem telling me a limit was hit. It seems
I had to fool around with this even before I rewired my control box. In the old control panel each limit
switch was wired separately to the BOB. This new wiring is sharing the BOB inputs for multiple axes.
I`m lost!!

Offline Hood

*
  •  25,779 25,779
  • Carnoustie, Scotland
    • View Profile
Re: Limit switch reset problem
« Reply #1 on: January 04, 2015, 05:13:32 AM »
If you attach your xml I will take a look.
Also are your switches Normally Closed or Normally Open?
Hood
Re: Limit switch reset problem
« Reply #2 on: January 04, 2015, 09:58:56 AM »
NC for the limits...thanks for taking a look.




Offline Hood

*
  •  25,779 25,779
  • Carnoustie, Scotland
    • View Profile
Re: Limit switch reset problem
« Reply #3 on: January 04, 2015, 01:05:58 PM »
The only thing I see at the moment is that your X axis Home switch is set to the same port/pin as the A axis switches. Dont really see how that would make a difference but I am presuming that is not the way you have them connected as you dont have the A axis enabled.

Hood