Hello Guest it is September 20, 2021, 09:55:04 PM

Author Topic: Win XP installation woes - G-code stops at first motion line  (Read 1737 times)

0 Members and 1 Guest are viewing this topic.

Win XP installation woes - G-code stops at first motion line
« on: December 19, 2014, 03:32:57 PM »
Hi greetings.  I have an older XP laptop (only thing I could find with parallel port)  that was/has/is running various versions of Mach3.  I agreed to help a friend set this up or reconfigure for some new driver boards.  After struggling with an unknown parallel port configuration for while because of poor documentation I got with the driver board, I opted to download the latest Mach3 software.   

At this point I broke something with the Mach3 software.  Now, no matter which version I run, If I load a demo g-code say "roadrunner.tap" after reset and cycle start it stops at the first G0.  After a little bit more trouble shooting I realize it will stop at any line that would produce motion.  Keep in mind this is without anything actually configured.   To prove I wasn't crazy to myself, I downloaded the latest mach3 on my desktop machine (7 pro) and sure enough out of the box without any configuration it will at least run through the demo g-codes.  That is how I remember it should work as I have been able to dry run gcode in the past without any physical port connection.

On the PC in question, I have tried older versions, etc.  I have uninstalled and reinstalled many times.  I even hand edited the registry at some point to completely remove any possible lingering installations before installing fresh.

Any ideas here?  is the port configuration on the PC able to effect the way mach3 runs without anything connected?  I have tried different port settings , EPP, bidirectional, etc but nothing seems to make a difference. 

Is this something dumb I have overlooked?  Estop? I have searched the forums and haven't seen anything exactly like this but please relocated thread/topic if there is a more suitable location for it.


Re: Win XP installation woes - G-code stops at first motion line
« Reply #1 on: December 19, 2014, 06:12:50 PM »
Ok - I have made some progress.   Using a couple of different XP and 2K machines (with and without port driver installed and with and without physical ports) I have figured out the following.    (using diagnostics page and windows device manager.. )

 - if you don't have a port, you get a pulse frequency of "simulated" - and you can dry run g-code

 - if you do have a port, and you install the port driver you get a pulse frequency of 25 kHz+ or something positive depending what you config - and you can dry run g-code

 - if you do have a port, and you un-install the port driver you get "simulated" again.  and you can dry run g-code

and my one weird case which has me stumped because this is the computer I need to run this on...

 - I have a port, I installed the driver, and I get a pulse frequency of "0".   and this is the situation that won't run motion.  

So - the new question is, what causes the port frequency to be "0".  Is this a driver/port problem? or a setting?