Hello Guest it is December 12, 2019, 02:07:22 PM

Author Topic: Can't get the Motor tuning screen  (Read 1981 times)

0 Members and 1 Guest are viewing this topic.

Offline rdean

*
  •  94 94
    • View Profile
Can't get the Motor tuning screen
« on: December 09, 2014, 04:07:25 PM »
I did some work on a fourth axis today and wanted to change the settings in Motor Tuning but nothing happens when I click on it.  Thought it was locked but not the case as I clicked on unlock and nothing came up either so I clicked on lock and it asked for a password.  Entered a password and the lock worked so went back and did unlock.  Motor Tuning still doesn't work but everything else does.

Used the XML editor to set what I needed for the fourth axis and that is working fine.
It would sure be nice to have motor tuning screen working again though.
Any Ideas?

Ray

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Can't get the Motor tuning screen
« Reply #1 on: December 09, 2014, 07:02:35 PM »
Try renaming your plugin folder to Old Plugins and then create a new empty folder. Obviously any plugins you actually use will need put into the new folder.

Hood

Offline rdean

*
  •  94 94
    • View Profile
Re: Can't get the Motor tuning screen
« Reply #2 on: December 09, 2014, 07:30:50 PM »
I will give it a try tomorrow.
Thanks Hood


Ray

Offline rdean

*
  •  94 94
    • View Profile
Re: Can't get the Motor tuning screen
« Reply #3 on: December 10, 2014, 10:13:06 AM »
Tried that today but didn't help. I just left the new PlugIns file empty.
Any other ideas. 
Maybe something in the XML file that I can change?
I have the ESS and a MPG plugin that I am using.

Thanks
Ray

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Can't get the Motor tuning screen
« Reply #4 on: December 10, 2014, 05:29:43 PM »
Maybe try installing Mach over the top of itself and choosing to install the driver, just make sure you have a backup of your xml etc in the unlikely event something goes wrong.
Hood

Offline rdean

*
  •  94 94
    • View Profile
Re: Can't get the Motor tuning screen
« Reply #5 on: December 10, 2014, 05:53:43 PM »
I think the problem started when I install a plugin for my MPG but I am not sure. 
I have modified the main screen to add two buttons for the router but that was months back, could I have done something there?

I will try the install

Thanks
 Ray

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Can't get the Motor tuning screen
« Reply #6 on: December 11, 2014, 04:07:26 AM »
Does sound like its a plugin issue but think you said you tried with the plugins folder empty, so that should have sorted it if it was, although you would likely have had to have the ESS plugin in there.
Modifying the screenset should not do that, so unlikely that the buttons are the problem.
Hood