Hello Guest it is October 19, 2019, 04:04:51 AM

Author Topic: sync failure  (Read 2270 times)

0 Members and 1 Guest are viewing this topic.

sync failure
« on: December 05, 2014, 10:59:15 PM »
The system was working well without charge.  Now with the weight of a 2.20 x 1.2 meters (although it is a low friction system you can move with one finger), frequently stops at the begining of a movement (jog or g1) saying that external movement is disconnected, and some times saying that Sync has failed.   Disconnecting the usb card and reconecting let me the system working but something that worries me is that at the beginning I moved the system with few problems but it is increasing the sensibility of the system giving each time more frequently the sync failure.   

The one who sold me the equipment told me to increase the steps per unit (5.814 steps per mm), but this is my tested calibration so one meter movement is acomplished with less than .5 mm of difference.    i would try changes with velocity or acceleration (about 1500 mm/min and 500 mm/s2) .   Well, I could use the first level of microsteps on drivers and set the steps per mm to double. loosing in max velocity, I think. 

Do somebody with more experience would like to give me some advice?

Luis J

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: sync failure
« Reply #1 on: December 06, 2014, 07:21:04 AM »
It wont have anything to do with your steps per unit, so ignore the advice you got from the seller.
Sounds like your device is losing contact with Mach.
You could look in device manager in the USB root hub and under power management see if it has the option  that allows Windows to shut it off to save power, if it does then remove it. Hopefully that will help.
Hood
Re: sync failure
« Reply #2 on: December 09, 2014, 02:05:50 AM »
Hood
The option you told me about windows controlling the energy of usb is not set.
It worked for a while, then it fails sistematically showing the message "External movement is disconnected".  I reset the card disconnecting the usb cable, so, when I reconnect it seems to work, but in about 3 seconds the message comes again.  Even the keyboard (usb) fails retarding the response to show the letters typed.  It makes me think is something related to the usb port.   The computer is a cheap Lenovo but it is new.  It has 4 usb ports, 2 for keyborard and mouse, the third is used with the usb-cnc card, the fourth is empty,   I calibrated the two axis, then did some movements with G codes for both axis, but since the last fail I can't make it work.  The other hint is that the jog function doesn't work.  In fact, the fail began when I tryed to move the system with arrow keys.   Could it be a tunning fail?  (Do the velocity and acceleration of motor tunning affects the movement of programmed feedrate or only the jogging movements?)  I'm separating other cables from the usb cable to limit induction.   Maybe I have to put a mass connected conductive protection to this cable.   
The other option is that the breakboard be failing but  Why it has worked alternating with fails?.
This last card interact with another circuit card for Z control.  I will contrast to know if it could be origin of fails, although it seems not to be the cause.
Thank you for your help.
Luis J.



Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: sync failure
« Reply #3 on: December 09, 2014, 07:04:39 PM »
If the keyboard also fails then it may indeed be the motherboard and USB that has issues.
Hood
Re: sync failure
« Reply #4 on: December 10, 2014, 11:20:30 AM »
I have tryed with another computer and another operating system (win 7, the first had win 8) and do the same.  I'm covering the usb cable with aluminium foil connected to mass supposing the problem is electromagnetic noise, I'll see if this works today. 

 
Re: sync failure
« Reply #5 on: December 10, 2014, 03:46:21 PM »
It worked!!!!!
So the problem was electromagnetic noise.
It has to be considerated I have a USB extention because the drivers are mounted in one axis structure in order to simplify cabling.   So the machine with mach3 need a long usb cable to reach the breakboard (3 m) wich will move in a range of 2 meters.   I wrapped the usb cable with 0.20 Euros of aluminium foil and then wrapped again with isolating tape.  (The seller of the card told me to find a blinded usb cable that I could't find in this town and costs about 25 Euros)  It works perfectly.  I will only fix some mechanical details and I will have the system operating.

Thank you very much for your interest and time.  I could send you a picture of the system later if you want.

Some persons use "sincerely" to finish a letter,   What would be right for you?
Luis Jimenez Illescas

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: sync failure
« Reply #6 on: December 10, 2014, 05:27:50 PM »
Thats great that you have solved it :)
And pics are always good ;)

Hood