Hello Guest it is December 03, 2020, 09:13:54 PM

Author Topic: odd problem with DRO's  (Read 2954 times)

0 Members and 1 Guest are viewing this topic.

odd problem with DRO's
« on: November 19, 2014, 08:31:51 AM »
I have an interesting problem. I have Mach3 with a Galil DMC-1840 controller set up in Windows XP, with the Galil-ST plugin. This is connected to a Bridgeport knee mill with 3 axis servo motors. The servo motors are all connected and tuned. Mach 3 connects to the Galil controller and the motors all move in the correct direction and what seems to be the correct amount. My problem is that the DRO values for the X,Y,and Z axis do not change when the motors move. Even when not connected to the motors, when I input a move from either MDI or the MPG jog mode the DRO still reads zero. If I teach a program and run it, the simulator shows movement, but no DRO change. However if I click on the To Go button the DRO counts down the move and works as I think it should.

I have another system running Windows 2000 with a DMC-1750 controller and the DRO's read as they should. Did I miss something in set-up or what could be causing this?
Re: odd problem with DRO's
« Reply #1 on: November 19, 2014, 10:23:14 AM »
I ran some tests on the controller using the Smart Term program. My program was
MT -1,-1,-1
CE 10,0,0
DP 0,0,0
PR 1000,1000,1000
WT 1000

This should zero the position counter, then produce a move of 1000 counts on each axis. The result is that the position counter is not advancing, it remains zero. The TE command shows an error increasing by 1000 counts on each axis for each pass through the program.

I performed a master reset and upgraded the firmware, but no change. I ran a Test Controller command, and it reported no problem.
Any ideas if maybe the DMC-1830 board has a bad component?
(No subject)
« Reply #2 on: January 08, 2015, 10:37:57 PM »
Not sure if this is the same thing I experienced this weekend but sounds similar I am running a dmc-1880, everything has been running perfect for more than two years. Then I decided to update the plugin to the latest. (4.6) and galiltools driver, all axis would only jog right, jog left, no movement and an error message. When jogging right my dro did not change. Finally I went back to galil plugin (4.4) and ver7 drivers and everything returned to normal the latest update may have left PCI cards in the dust.
Re: odd problem with DRO's
« Reply #3 on: August 27, 2016, 03:52:56 PM »
I re-ran the test on the DMC-1830 and the DP counter is working correctly. I do have ver 4.6 of Galil-st.m3p installed. Do you know where I can find ver 4.4?