Hello Guest it is May 08, 2021, 05:29:29 PM

Author Topic: Mod-IO communication problem  (Read 4042 times)

0 Members and 1 Guest are viewing this topic.

Mod-IO communication problem
« on: March 28, 2007, 02:08:37 PM »
Hi All,

I have a Homann V4.1 Mod-IO board that I have swapped with an existing (V2.2) board in my pendant (dead DOUT1), but am having some trouble getting the communication link to work properly.

I get a flashing left green light (input to Mod-IO) but am not getting any flashing activity on the left red LED (output). Indeed, I am reading info from Mach on the LCD, but can get no activity out of the Mod-IO card to Mach. I have the ID set to 6, 57,600, 8-1-n. All settings on computer and Mod-IO look to be in sync. Sometimes I get a flashing red light (right side near selector switch) but other times it is off, but still no output from the unit.

When I open the Modbus Status & Control dialog, input and output slave address is set to 6, start reg is 1150 and 1040 respectively, and MODIO Modbus card checked, click on CONFIG button I get “No Connection to Homann Board”. No matter what I do I can’t get this to show a connection. I don’t recall having any such difficulty with the initial unit.

Any ideas that might propel me over this patch of dead-water??

Thanks a bunch for any input!!


Offline Graham Waterworth

  • *
  •  2,322 2,322
  • Yorkshire Dales, England
    • View Profile
Re: Mod-IO communication problem
« Reply #1 on: March 28, 2007, 07:07:50 PM »
Is JP4 set to RS232 (pins 2-3) or RS485 (pins 1-2), it should be RS232.

Is the selector wheel set to zero ?

« Last Edit: March 28, 2007, 07:19:33 PM by Graham Waterworth »
Without engineers the world stops
Re: Mod-IO communication problem
« Reply #2 on: March 29, 2007, 05:55:30 PM »
Hi Graham,

Thanks for your reply and suggestion. Indeed, the wheel is on zero and JP4 is (I believe) on 2-3. Its actually difficult to tell but on V4.1, there are three 3-position jumpers adjacent to the LCD connector; JP7, JP12, and JP4. 7 & 12 are in the positions of 1-2 (farside of LCD connector) while JP4 is at the near-side of the connector. I think the position 1 is identified by a square but it is difficult to see for certain.

The V2.2 has the JP4 in a similar location and jumpered in the same fashion. It worked fine pretty much out of the box, but not this one. I've gone back to square 1 several times, but end up at the same point.

Unless anyone has any further ideas, I'm going to put the old one back in and do without the DOUT1.

Thanks Again!!


Re: Mod-IO communication problem
« Reply #3 on: April 02, 2007, 11:00:47 PM »
Graham and All,

I worked out my problem after a serious troubleshooting effort.

After putting the old card back in and finding they both displayed the same unresponsive characteristics, I figured it had to be somehing in the computer. I checked and rechecked everything multiple times. Mapped all resources and interupts. All OK. I brought in another Com port. No change. Then I brought in another computer... And everything worked like it should. Hmmm... So, I went back, removed Mach and reinstalled. No change. Removed P-ports and Mach and (after numerous BSDs and hangs) reinstalled and tadaaa, it started working.

Something in the system was in conflict, and I do not know specifically what it was. I do know that some combination of the NETMOS dual Par-port card & drivers (I use these as my Mach connection) and the Mach3 driver was keeping the Com ports from working properly. In general, I find the NETMOS 97x5/98x5 series of chips to be onery, and this proved no exception. I do computer and network support work for a living and this was one of the more frustrating troubleshooting jobs I have had in some time.

That's the story here. Best to All,