Hello Guest it is November 13, 2019, 06:30:10 PM

Author Topic: Cant find the answer in the others threads.....  (Read 2201 times)

0 Members and 1 Guest are viewing this topic.

Cant find the answer in the others threads.....
« on: August 08, 2014, 11:44:04 PM »
I purchased a 3020(chinese) router just to get the hang of things before i purchased a costly one.  OK... so heres my problem, when my router is running a program the step motors lurch through the cuts BUT when i move the mouse around they run smoothly.  I am using a wireless mouse not sure if that has anything to do with it or not.  I know it sound s crazy but has anyone had this problem or know of a thread to recommend?
Re: Cant find the answer in the others threads.....
« Reply #1 on: August 10, 2014, 06:17:54 PM »

I've got the intermittent pulse frequency issue, it drops down to 5k or so, then when i wiggle the mouse it jumps up to 25k or so.

After asking around about what exactly the issue is, i developed a theory and tested it.

One of the "fixes" that was posited was to increase the size of the tool path window. which ate up more cpu time, stabilizing the pulse frequency.(Thanks Chip!)

So based on the idea that CPU speed was part of the issue and eating up cpu speed to decrease the effective cpu speed was a fix, i set out to do just that as simply as possible.

I downloaded a program of a class that we used to use to slow down old games of fast computers, back before frame limiters were standard technology.
One example of this is the one i used, here;

http://www.cpukiller.com/

It's free and Had the Cnet seal of approval. It also allows you to slow you effective cpu speed as a percentage of your total cpu speed.

So my theory is that mach 3 was tuned for a 1ghz processor, so my 1.5ghs box, needed to be slowed down to 1ghz. a factor of 33%.

I booted CpuKiller, set the slowdown to 33%, ran mach, and my pulse frequency was a steady as a rock above 25k.

I had already done a bunch of the optimization stuff and never got a good pulse frequency. Cpu killer and an effective CPU speed of 1ghz fixed my probelm.

Alternately I believe that EFFECTIVE pulse frequency needs to be 1ghz, or a multiple of 1ghz, i believe that mach can adjust a little, but if you
exceed that limit, bad pulse frequency. But since my test machine was 1.5ghz, I was not able to test this theory out. The more software and interrupts you have running the more your effective cpu speed will differ from your advertised cpu speed.

found this buried in the forum....................


I hope this helps someone who has the same problem.

If you try it and it does or does not work, try adjusting the slowdown up and down to see if your effective cpu is not your reported cpu speed, find the setting that works for you. Targeting 1ghz should be a safe first guess.

If you want to find out your effective cpu speed, go to a command prompt and type in dxdiag.exe , if you have DirectX installed it will bring up a ton of info about your machine including the advertised CPU speed (on the system tab),
Re: Cant find the answer in the others threads.....
« Reply #2 on: August 10, 2014, 06:39:49 PM »
I did not come up with this fix but it worked for me so I reposted it................

Offline Tweakie.CNC

*
  • *
  •  7,986 7,986
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Cant find the answer in the others threads.....
« Reply #3 on: August 11, 2014, 02:01:16 AM »
Excellent information Outlawkt - thanks for posting  ;)

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.