Hello Guest it is August 22, 2019, 12:30:53 PM

Author Topic: Why can't I add a button to the Mach3 screen using Screen4?  (Read 2061 times)

0 Members and 1 Guest are viewing this topic.

Hello everyone. I don't know why but I am having trouble adding a scriptable button to Mach3's Run Program screen. I open Screen4, File, Open, 1024.set, and it opens up. The DRO's are counting up in the plus direction. I can see the Button control under the Controls Workspace area. When I click on the BUTTON, it lights it up orange. When I move the cursor into the Mach3 screen area, it is still an arrow. When I click on the area I would like to place my new button, the cursor turns into a plus with arrows on each end as if to move whatever I clicked on. No button gets placed. When I try to drag and drop, it gives me a slashed circle meaning "nope". Does anyone have any ideas? Does Mach3's "Program Run" screen already have the maximum amount of buttons allowed? Any help would be greatly appreciated. It should not be this hard. Oh well, thank you all for reading this and I wish you all well.  Benji.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Why can't I add a button to the Mach3 screen using Screen4?
« Reply #1 on: July 22, 2014, 02:37:28 PM »
As the standard screenset has a background image you will have to disable that first. If you look at the top you will see Img with a \ through it, click that and you will be able to add buttons, DROs etc.
Word of warning with screen4, when you have added the buttons or DROs or whatever it is best to Click None before you do any editing, if you dont it is very easy to inadvertently add extra buttons/DROs/LEDs each time you click.

Hood
Re: Why can't I add a button to the Mach3 screen using Screen4?
« Reply #2 on: July 22, 2014, 11:33:36 PM »
Ok thank you Hood. I appreciate your timely and considerate reply. Best wishes to you. Benji.