Hello Guest it is July 14, 2020, 07:07:50 PM

Author Topic: Odd Stepper behavior  (Read 5681 times)

0 Members and 1 Guest are viewing this topic.

Odd Stepper behavior
« on: April 03, 2014, 08:51:34 AM »
I've just finished converting my G0704 Mill to CNC.  I am now tuning my steppers and dialing in the system. 

Here is the set-up:
2 Nema23 steppers on X & Y
1 Nema34 stepper on Z
3 KL-5056D drivers
C35 BOB
Kl-600-48v power supply
Mach3 - running Version .066
Older desktop dedicated to the mill.  600Mhz CPU, WindowsXP SP3.0.  Stripped of extra programs and crap.

25k Hz, Sherline 1/2 pulse checked, 8000 steps per (validated in the ballpark with tape measure for now)

The driver test checks out "Excellent".

So here is the oddity in behavior.  While I am in the Motor Tuning, I can set my XYZ axis velocities pretty high (about 250in/min) and the steppers sound great.  No stalling, no missed steps - nothing.  Just humm back and forth to my up/down keyboad commands.

Now as soon as I exit the Motor Tuning window and get back to the Mach screen and jog the axis, they sound like they are missing steps, like there is a chip in the bearing.

I've reconfigured for 1/4 and 1/2 micro stepping and get the same results.

Any ideas where to look or test?

Thanks for the help.

-Mike
Re: Odd Stepper behavior
« Reply #1 on: April 03, 2014, 09:32:28 AM »
Last night I took a picture of the Diagnostic Screen and this morning I was comparing it to some images on Google and noticed my Pulse Frequency is reading in the single to double digits.  Other random screen shots show it at 24-25k which make more sense to me....

If my driver test passed, why am I seeing an extremely low pulse frequency on the diagnostics screen?  Do I need to be jogging an axis for this to show up correctly and this is just an "idle" condition?  Perhaps someone can verify that your Pulse Frequency is always showing around 25khz regardless of e-stop, idle condition, or during jogging.

Thanks

-Mike

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Odd Stepper behavior
« Reply #2 on: April 03, 2014, 05:01:09 PM »
Your frequency should show as, or very close to, the kernel you have set. If it is not or varies widely then you have issues.
However a 600Meg CPU is well below recommended specs and it certainly wont be helping matters.
If you were using an external controller then 600Meg may be ok but I would say it still may be borderline.

Hood

Offline ger21

*
  • *
  •  6,282 6,282
    • View Profile
    • The CNC Woodworker
Re: Odd Stepper behavior
« Reply #3 on: April 03, 2014, 05:06:40 PM »
Quote
If my driver test passed, why am I seeing an extremely low pulse frequency on the diagnostics screen?

The driver test doesn't tell you for sure if your PC will work. It's really a bit deceiving at times.

I'm with Hood, I think your PC is just too slow for Mach3. Try turning off the toolpath display and see if it makes a difference.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Odd Stepper behavior
« Reply #4 on: April 03, 2014, 11:01:38 PM »
I can pick up a 1.4Ghz P3 processor on EBay for $7. Can't really go wrong with trying that.

I've turned most everything off already.

Thanks for the suggestions.

Mike

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: Odd Stepper behavior
« Reply #5 on: April 05, 2014, 11:29:10 AM »
   Mike I am not sure where you live. Oddly enough the computers Mach needs are not special. Ask your neighbors if they have any old computers around. I was happy to finally find a purpose for some of the computers I refused to throw out due to my fear someone else might discover my secrets on my HD's. I am not sure of what those secrets are but I sure didnt want anyone else to know what they were either. Important stuff like my Machsupport password. You know things you probably cant remember ;-)
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)
Re: Odd Stepper behavior
« Reply #6 on: April 08, 2014, 07:41:51 AM »
OK, no luck.  The new processor was not recognized by my BIOS and wouldn't even boot up.  It was only $7, so I'm not upset.  I think my computer is just tooooo old and underpowered.  I don't think it's worth the effort to update just to bring up to the min spec required for Mach3.

I'm going to look for a refurbished/used computer on eBay now - I've asked around and no one has an old computer sitting around.  Does the PP have to be integrated into the MB or can I just use a plug-in PP card?

I've seen real nice deals on 2Ghz P4 Dell Optiplex GX260 with WindowsXP loaded for $75 shipped on eBay.  Any reason to stay away from those?  I've heard that Dell ties the OS license into the BIOS which requires you to need the original installation disk if ever you have to reload windows....truth?

Just looking for some guidance to make an educated computer purchase.  I've been reading random computer threads for Mach3 which have helped.

Thanks.

-Mike
« Last Edit: April 08, 2014, 07:48:04 AM by MikeSherman »
Re: Odd Stepper behavior
« Reply #7 on: April 08, 2014, 09:06:48 AM »
....and how important is a non-integrated video card?  
Re: Odd Stepper behavior
« Reply #8 on: April 08, 2014, 10:22:05 AM »
Mike,
I have used three Dell GX270s, and they all ran Mach3 well, BUT, the capacitors on the motherboard are prone to going bad, especially considering their present age.  All three are now kaput.  As far as the license goes, buy one from a refurbishing dealer who will supply OEM/restore disks with the computer.

John Champlain
Re: Odd Stepper behavior
« Reply #9 on: April 08, 2014, 10:34:51 AM »
John - thanks for the input.  You make a good point too!  I'm substituting on older computer with a not-as-old but still older computer...hahaha

I was budgeting about $100 for this new computer.....for $125 I can get the UC100 USB Motion Controller: http://www.cnc4pc.com/Store/osc/product_info.php?cPath=93&products_id=481

Then I can just use my more current home computer. 

There is a good article on CNC cookbook discussing PP vs External Motion Controllers here: http://blog.cnccookbook.com/2011/12/24/motion-control-boards-take-mach3-from-hobby-class-to-industrial-grade-part-2/

Are there any downsides to going with the UC100?

-Mike