Hello Guest it is January 29, 2020, 10:25:28 AM

Author Topic: G21 problem  (Read 1746 times)

0 Members and 1 Guest are viewing this topic.

G21 problem
« on: January 14, 2014, 06:22:32 PM »
Hi all,

I've somehow gotten my units all mangled and now Mach3 seems to ignore g21 commands...

I am trying to setup a new xml for a 3d printhead I just built.  My workflow goes Rhino (mm) to Slic3r (mm) into Mach3 (inches).  In the past, I have just included g21 in the code and all worked fine.  But after fiddling with the motor tuning (for the sake of the print head), now when I inter G21 in the MDI, the feedrate is adjusted (x25.4) but the DRO does not, and so the machine tries to make a huge part.

Can someone set me straight? 

Thanks!!!!!

dh

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: G21 problem
« Reply #1 on: January 14, 2014, 06:43:31 PM »
If your workflow is in mm's, then set up Mach3 in mm's. It'll save you a lot of headaches down the road.

Anytime you have an .xml that doesn't behave properly, imo it's best to delete it and start over from scratch. Once you get a good working .xml, make a backup of it.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: G21 problem
« Reply #2 on: January 15, 2014, 12:33:09 PM »
Hi Ger21

I just cloned an xml, changed the native units from inch to mm, and the DRO didn't change.
So just to be sure, I went to the MDI and entered g21.  Nothing changes
I move the z axis 1.00 unit, and it moves 1.00"
Enter g20 in the MDI and the DRO changes numbers.
Now if I want to move 1.00" the DRO reads .0394

So, it's like g21 and g20 are reversed... (?)

I've tried with "Lock DRO to setup units" ticked and without.  

I have a load of in/outs, macros, Ethernet SmoothStepper, etc. that make the thought of a fully-virgin setup really unappealing.  Is there any way to work through this one issue?

TIA

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: G21 problem
« Reply #3 on: January 15, 2014, 12:42:32 PM »
Are your steps/unit set correctly? If you change the native units, you need to change the steps/unit as well.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: G21 problem
« Reply #4 on: January 15, 2014, 01:00:08 PM »
lol - exactly.  With "mm" selected as native units, Divided the steps by 25.4.....

Sorry for the brain fart!

thanks!