Hello Guest it is March 09, 2021, 03:00:50 AM

Author Topic: Rotational Soft Limits on A axis, once more, cannot be disabled.  (Read 12114 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #10 on: January 04, 2014, 10:24:22 AM »
He is, as far as I understand, homing the axes.
Hood

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #11 on: January 04, 2014, 11:47:25 AM »
Hood, what is your version of Mach3? I will then do a clean install of the same version.
Peter.

+ do you have the driver installed at home (the video computer)?

It is 062 here.
 I have just noticed your edit, I do have the driver installed as some things do not work correctly if you use in Simulation mode. Having the driver installed does not mean you have to have a printer port on the computer, so I always install it unless it is on a machine where I will be solely using an external controller.
Hood

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #12 on: January 04, 2014, 11:52:10 AM »
I have also just tried with 066 which I see you used and again it works fine, going back to 062 though as 066 has issues ;)
Hood
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #13 on: January 04, 2014, 12:29:19 PM »
Hi all,
sorry when I enter this thread.
So far as I remember there is still a glitch in Mach and rotational Soft Limits.
I think that was discussed before in the forum. I put in  +-999999999999 in Homing/Limits for the A axis and its fine.
Note that Mach is counting and saving the G53 position when the axis is not referenced. You may reach the limit one day.
Just a thought.

Alex
For some people, Rotational Soft Limits Unchecked is honored, for others - not.  See the video of Hood.

The axis A is referenced on my system, but I will see what changes, when only X Y Z are referenced, and A is not referenced. Thanks for the hint.
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #14 on: January 04, 2014, 12:34:12 PM »
Regarding the soft limits, if that is the way you feel is safest then you would be better making it foolproof.
To do that you would edit the VB in the RefAll button, have it first disable Soft Limits, next have it home the Z axis and then move the axis the distance required, then Y then X, again having them move the required distance, then finally have it re-enable soft limits.
Hood
I consider augmenting your proposal to the ZERO ALL button (as is it named in my screen layout, which is a slightly modified SIEG.set, which in turn is probably based on a very old version of 1024.set).
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #15 on: January 04, 2014, 01:14:10 PM »
I shall verify that the Soft Limiit button on my "old" screen is the same as the current Soft Limit button, perhaps it is now a OEMButton.
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #16 on: January 04, 2014, 01:16:43 PM »
short update from here.
Tested some things and as Hood says no problems here in .062 and Printer Port but still problems by using the SmoothStepper
so it is the SS Plugin with the glitch.

Alex

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #17 on: January 04, 2014, 03:23:01 PM »
Just tried with Peters profile and a SS (V17-D plugin) and its fine.
Hood
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #18 on: January 04, 2014, 04:18:10 PM »
It does oviously not depend on the Mach version, and I could not do a clean install yet, or vary my other circumstances.

Here is my current screen set (attached), and it refers to the plain MillBitmaps. Maybe the screen set contents makes the difference. Can you try it, please, Hood?

Maybe soft limits on A are handled by the driver... there is another option, M5 macro command that works only with the driver.

I'm running on a Windows 8 32 bit, on a virtual computer, and I doesn't install the driver. I do have the option of a virtual Windows 7 32 bit. The host is a Windows 8 / Windows 8.1 64 bit Intel i7.

Peter.
« Last Edit: January 04, 2014, 04:28:36 PM by PeterF »

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #19 on: January 04, 2014, 05:09:13 PM »
Ok now that I know that I would say that is almost certainly your problem. With a 64bit OS you can not run the PP driver and as such you are in Simulate mode and as said previously things often dont run right in sim mode. I will go and try your profile in sim mode and report back.
Hood