Hello Guest it is January 29, 2020, 01:09:14 PM

Author Topic: Rotational Soft Limits on A axis, once more, cannot be disabled.  (Read 10901 times)

0 Members and 1 Guest are viewing this topic.

I too cannot disable rotational soft limits. The check box Rotational Soft Limits from Config/General Logic/Rotational pane goes into the XML as ROTSOFT, but Mach3 regardless of the checkbox and ROTSOFT, does soft limits on A. I went thru all the ~12 posts here about the rotational soft limit issue. On some posts, the checkbox Rotational Soft Limits seems to work, on other posts it does not work.

My Mach3 for this issue is versions R3.042.033, R3.042.038, R3.042.040  and R3.043.066. I also did the usual things with the XML: removed ROTSOFT, added RotSoft, varied every conceivable parameter in the Config menus, without any result. This is a test system without actual CNC, even without parallel port. The PROFILE is attached. We need Soft Limits turned on for the X Y Z axes.

Of course I can do infinity limits on A, up to +36500000.00, -36500000.00  (five zeros, a hundred thousand turns). But six zeros are too much, giving a Max<Min status message.

I thank you in advance for help.

Peter.
« Last Edit: January 03, 2014, 06:14:26 PM by PeterF »

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #1 on: January 03, 2014, 07:27:25 PM »
Rotational soft limits are disabled in that xml and I also jogged the A right up to 360 and it rolled over so that confirmed to me they are not enabled.
Hood
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #2 on: January 04, 2014, 04:47:51 AM »
Hood,

The soft limits are in that XML:
X: 279;-1
Y: 130;-1
Z: +1;-265
A: 365;-5

The home (reference) positions are:
X: -5
Y: -5
Z:+5
A: 0

Rotational Soft Limits are unchecked.

Did you try to rollover from 360 up to 365 and more in the 4th axis? Did you try to roll over from 0 down to 355 and less, and soft limits did not fire on your Mach3?

(When you try and are at the reference positions, you have first to move away in X, Y, and Z and only then turn on Soft Limits. At the reference position, X Y and Z would fire soft limits) Thanks in advance for your help.

Peter.
« Last Edit: January 04, 2014, 04:50:33 AM by PeterF »

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #3 on: January 04, 2014, 05:07:09 AM »
Why you would have a home off value of -5(X and Y) 5 (Z)  I am unclear as basically that is telling Mach to set the machine coords 5 units past  zero,  but I am sure you have your reasons ;)
In any case it makes no difference here, soft limits are not active for the A axis, I can jog right round as many times as I wish.
Hood
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #4 on: January 04, 2014, 08:26:30 AM »
A) The coordinate reasons are these:
the operator moves safely, in machine coordinates, in X, from around 0 to around 278.
the soft limits are -1 and 279.
the end switches are at -5 and at 285.

The soft limits are within the end switch hard limits.

Main reason: Machine coordinate zero is defined, it is within the soft limits and within the end switches. It is useful to have a GOTO MACHINE ZERO button, and we do have it.

The distances between the end switches, soft limits and machine coordinate 0 are a bit arbitrary, admittedly. (at the lower X for example: -5; -1; 0).

B) Why can you roll around in A, and I cannot? I do not have the driver installed, makes this the difference?
« Last Edit: January 04, 2014, 08:32:18 AM by PeterF »

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #5 on: January 04, 2014, 08:50:34 AM »
Video here, I changed 3 things in your xml, first was the screenset as yours is a custom one and I dont have it. Second was the port addresses as the ones you have made my computer hang for a bit then trip the driver watchdog. Third, halfway through the video I changed the Velocity of the A axis to speed things up a bit for the video.
BTW just in case you wonder why the DROs look a bit jumpy it is just because of the capture rate of the screencaptur software.

http://www.youtube.com/watch?v=M940DUbuvDA&feature=youtu.be

Regarding your softlimits, I personally do not see a reason for having it set the way you do. If you have Home Off as zero and Min as Zero and you adjust the slow zone correctly then you should never be able to hit a limit switch by jogging onto it. Reason being is when homing Mach will move the axis onto the switch and then back off again. When the switch closes that is the position that is set as machine zero. So if you jog towards that switch the softlimits should stop you exactly at zero, ie the position the switch closed at, you should not be able to move past that position and hit the switch. If you do not have the slow zone set correctly then it may be possible for you to overshoot, so set that correctly and all will be fine.
 The way you have things set up means to home the machine softlimits need disabled, this then means that after homing you need to jog a bit before you can then enable them, if you are concerned about the operator not doing things correctly (as your previious post would suggest) then not having to first disable then next remember to enable, after a jog, would be safer in my opinion. Obviously thats just my opinion though ;)
Hood
« Last Edit: January 04, 2014, 08:52:48 AM by Hood »
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #6 on: January 04, 2014, 08:59:18 AM »
The way you have things set up means to home the machine softlimits need disabled, this then means that after homing you need to jog a bit before you can then enable them, if you are concerned about the operator not doing things correctly (as your previious post would suggest) then not having to first disable then next remember to enable, after a jog, would be safer in my opinion. Obviously thats just my opinion though ;)
Hood
Yes, your observations are right. For this I did Goto Machine Zero, and then turn Soft Limits on. And we have margin when turning the jog wheel (MPG on the second port) in the wrong direction at the reference position. It is also safer for me, as the IT people. The CNC is 100km from me.

The 4th axis video I look at it later this evening.
Peter
« Last Edit: January 04, 2014, 09:06:08 AM by PeterF »
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #7 on: January 04, 2014, 09:27:52 AM »
Hood, what is your version of Mach3? I will then do a clean install of the same version.
Peter.

+ do you have the driver installed at home (the video computer)?
« Last Edit: January 04, 2014, 09:44:06 AM by PeterF »

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #8 on: January 04, 2014, 09:35:03 AM »
Not sure exactly what version I have on that machine, it is the home one and I am now at the workshop, I will look when I get home in a few hours.


Regarding the soft limits, if that is the way you feel is safest then you would be better making it foolproof.
To do that you would edit the VB in the RefAll button, have it first disable Soft Limits, next have it home the Z axis and then move the axis the distance required, then Y then X, again having them move the required distance, then finally have it re-enable soft limits.
Hood
Re: Rotational Soft Limits on A axis, once more, cannot be disabled.
« Reply #9 on: January 04, 2014, 09:56:53 AM »
Hi all,
sorry when I enter this thread.
So far as I remember there is still a glitch in Mach and rotational Soft Limits.
I think that was discussed before in the forum. I put in  +-999999999999 in Homing/Limits for the A axis and its fine.
Note that Mach is counting and saving the G53 position when the axis is not referenced. You may reach the limit one day.
Just a thought.

Alex