Hello Guest it is April 18, 2021, 10:55:42 AM

Author Topic: Picture not okay....  (Read 6611 times)

0 Members and 1 Guest are viewing this topic.

Picture not okay....
« on: January 02, 2014, 07:59:01 AM »
Hi,
I have a picture 140x70mm and the cnc is starting from the middle, but when it is about 80% left it starts to go of track so it leaves tracks that are not mille...

What can I do??
I'm NEW at this....

Thanks!

Finland

http://www.hangonpuukko.fi/WP_20140102_001.jpg



Offline RICH

*
  • *
  •  7,419 7,419
    • View Profile
Re: Picture not okay....
« Reply #1 on: January 02, 2014, 12:13:59 PM »
You should view the gcode pathing to make sure there are no problems with the program before you run it.
Looks like you are loosing position and that could be due to a number of reasons.
Motors getting hot, motor tunning is boarderline, or even the motors don't are not adequate for the requested move.

Is the skipping reapeatable or random?
Post the gcode and your xml file.

RICH
Re: Picture not okay....
« Reply #2 on: January 02, 2014, 12:29:24 PM »
Hi,

Thanks For your help so far...

I have a CNC3040 and it runs about 45-60min at one time.

Here is the Gcode http://hangonpuukko.fi/pimu.txt

Offline RICH

*
  • *
  •  7,419 7,419
    • View Profile
Re: Picture not okay....
« Reply #3 on: January 02, 2014, 08:06:48 PM »
Code looked ok.
Post your xml file.

RICH
Re: Picture not okay....
« Reply #4 on: January 03, 2014, 03:19:33 AM »
Hi,
Sorry im new at this whats xml file?? Where can i get it?
Thanks!!

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Picture not okay....
« Reply #5 on: January 03, 2014, 03:27:09 AM »
The xml file is a file that holds the configuration for the profile you are using. If you open Mach and look lower right you will see the profile name you are using. Close Mach then browse to your Mach3 folder and in there you will see a file with that name a a .xml file extension. Copy that to your desktop and rename it to something unique, SirFinland1.xml , or similar. Then use the additional options button on the reply page to attach the renamed file to the forum.
Hood
Re: Picture not okay....
« Reply #6 on: January 03, 2014, 05:55:20 AM »
Hi again.....
I dont find any xml file in the mach3 folder just some mach3mill.xml, mach3turn.xml but not any of thoose i have made?...

Thanks!!

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Picture not okay....
« Reply #7 on: January 03, 2014, 06:20:36 AM »
There are 3 default xmls in Mach and if you use the standard profiles you will use one of them. For example if you just used the default Mill profile then your xml will be the Mach3Mill.xml. When you change any settings in Mach they get written to the xml each time you close Mach down.
Hood
Re: Picture not okay....
« Reply #8 on: January 03, 2014, 06:30:40 AM »
Okay,

Now i get hang off it ;)
I will put it here soon.
Thanks!!!
Re: Picture not okay....
« Reply #9 on: January 04, 2014, 07:15:11 AM »
Hi,

Here it is...