Hello Guest it is May 24, 2019, 10:11:13 AM

Author Topic: erratic behaviour after customizing screen  (Read 2804 times)

0 Members and 1 Guest are viewing this topic.

erratic behaviour after customizing screen
« on: November 08, 2013, 06:36:05 AM »
Hi All,

A friend helped me customizing my Machturn screen , sometime after that my steppers started acting in a strange erratic way.

After some experimenting it shows that running a program in the customised screen caused erratic steppers  but running the same program while in the diagnostics screen my steppers are behaving ok.


This is out of our league , i have attached  my screenfile can somebody please  help  out???


Thanks   Mark

Offline Hood

*
  •  25,816 25,816
  • Carnoustie, Scotland
    • View Profile
Re: erratic behaviour after customizing screen
« Reply #1 on: November 08, 2013, 08:35:03 AM »
Cant see how a screenset could make your steppers misbehave.
Hood
Re: erratic behaviour after customizing screen
« Reply #2 on: November 08, 2013, 09:19:56 AM »
Hi Hood thanks for your reply :  its absolutely true, if i change screens or run from diagnostic screen everything is ok.
Re: erratic behaviour after customizing screen
« Reply #3 on: November 08, 2013, 01:01:43 PM »
Pardon the question, but are you changing screen views, or profiles?
John Champlain
Re: erratic behaviour after customizing screen
« Reply #4 on: November 08, 2013, 01:41:48 PM »
Hi John,

No change in profiles , i just load my cncprogram into Machturn , when i run it in my customscreen my steppers go erratic,
when i change screenview into diagnostics everything runs ok.

Mark

Offline Hood

*
  •  25,816 25,816
  • Carnoustie, Scotland
    • View Profile
Re: erratic behaviour after customizing screen
« Reply #5 on: November 08, 2013, 03:57:22 PM »
The only thing I could possibly think of that would cause a screen to affect the steppers is if the screen is very graphic intensive and your computers graphics card is very weak.
Hood
Re: erratic behaviour after customizing screen
« Reply #6 on: November 09, 2013, 03:28:47 AM »
Well Hood, In fact my graphics are actually a bit on the weak size , is there a way i can test if this is the cause (other than changing my computerhardware)  ??

Offline Hood

*
  •  25,816 25,816
  • Carnoustie, Scotland
    • View Profile
Re: erratic behaviour after customizing screen
« Reply #7 on: November 09, 2013, 05:35:09 AM »
You could try either adding a button to disable toolpath view or temporarily remove the toolpath view from your screenset.
Hood
Re: erratic behaviour after customizing screen
« Reply #8 on: November 10, 2013, 01:56:33 AM »
Thanks Hood , will try that

Offline ger21

*
  • *
  •  6,233 6,233
    • View Profile
    • The CNC Woodworker
Re: erratic behaviour after customizing screen
« Reply #9 on: November 11, 2013, 08:02:24 AM »
If you have a very large toolpath display and a weak PC, that could be the issue. Try turning off the toolpath and see if it helps.
A few users of my 2010 Screenset had a similar issue. (about .1%)
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html