Hello Guest it is December 13, 2019, 04:54:14 AM

Author Topic: PoppaBear Question SCott??  (Read 18164 times)

0 Members and 1 Guest are viewing this topic.

Offline BR549

*
  •  6,916 6,916
    • View Profile
PoppaBear Question SCott??
« on: August 12, 2013, 11:49:21 PM »
HIYA Scott do you know of ANY indicator in the plugin side that tells you IF a G31 is running ??

Or do you know of any indicator in CB or the LEDS that does the same??

(;-) TP

Offline poppabear

*
  • *
  •  2,233 2,233
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: PoppaBear Question SCott??
« Reply #1 on: August 14, 2013, 01:45:07 AM »
Terry,

see "Beta" G31 Detect plugin I just posted under finished plugins......... 
http://www.machsupport.com/forum/index.php/topic,25264.new.html#new

IT IS BETA, so let me know if it works for you, and I will declare it release.....

scott
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: PoppaBear Question SCott??
« Reply #2 on: August 14, 2013, 11:20:50 AM »
HIYA SCott, It does not work here. I installed the plugin and then reloaded mach3 then set the userLED.

When I invoke a G31 it does NOT lite up the led. I tested the Userled with CB code and it works fine I can turn it on and off.

Sense you are doing the Plugin, the Function I was after was IF the Probed trips AND a G31 was NOT called then it issues a FULL STOP to mach3. It is called "protected mode" . It is to protect the probe when you are moving around getting into a position to probe. It does need to be able to be turned on and off when needed. It could be done via macro M*********x.

Thanks (;-) TP
« Last Edit: August 14, 2013, 11:23:58 AM by BR549 »

Offline poppabear

*
  • *
  •  2,233 2,233
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: PoppaBear Question SCott??
« Reply #3 on: August 14, 2013, 10:09:16 PM »
Here is the condition that I am testing it:

Under config, ports/pin, the PROBE input is enabled.

The plugin is looking at the "Probing" Boolean variable in the axis structures. When you issue a G31 z-1 command via, MDI.
the Boolean DOES become true, and when true, it sets the USER LED to true, if a G31 is NOT in effect it turns off the ULED.

While it is actively probing, (the G31 is currently active), it was MY understanding that if the "Probe" input signal goes high (the probe hit something), then that ends the G31 probing cycle.........

if the above understanding is what your doing, and getting NO results....... well then, it appears that I have NO clue what variable in mach3 land is the one to show that probing is currently active.

VB Macros......  If you can do it in a macro, then why do you need a plugin?

Scott
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: PoppaBear Question SCott??
« Reply #4 on: August 15, 2013, 11:37:36 AM »
One could do the turning on and OFF with a " macro". I have found NO CB indicator that tells IF mach3 is in G31 mode.

Maybe someone else could test it as well. COuld be a Vista problem here.

Thanks For the effort,

(;-) TP

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: PoppaBear Question SCott??
« Reply #5 on: August 15, 2013, 09:22:43 PM »
Scott does this work with your machine ?

(;-)TP

Offline poppabear

*
  • *
  •  2,233 2,233
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: PoppaBear Question SCott??
« Reply #6 on: August 15, 2013, 09:38:39 PM »
have no clue, dont have a probe, and my shoptask is down for a reconfig.
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: PoppaBear Question SCott??
« Reply #7 on: August 19, 2013, 07:07:41 PM »
HIYA SCOTT,  The plugin DOES work as I found out BUT it is locked to LED2000 , No matter what you choose in the config.

I found it by creating a report that showed all the active LEDS up to 3000. Then comparing to reports WITH and WITHOUT the G31 running

If you get time to look at it could you change the function to IF the probe is tripped AND NOT in G31  to issue "STOP" to mach3.

Also we need to be able to turn it ON and OFF via a Macro perhaps monitor another LED to turn it on and off ?

Thanks for the time, (;-) TP

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: PoppaBear Question SCott??
« Reply #8 on: August 20, 2013, 11:01:13 PM »
I do have a working PROTECTED MOVE mode now. IF you are not in G31 mode(probing) and the probe tip HITs an object Mach3 will STOP to protect the probe tip from damage.

This works with jogging as well.

Thanks TO Scott, (;-) TP

Offline poppabear

*
  • *
  •  2,233 2,233
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: PoppaBear Question SCott??
« Reply #9 on: August 21, 2013, 07:03:59 AM »
Hey Terry,

  Opps................  duh............  I forgot to tie the ULED selection to
The var for what ULED............  I will probably try and get it fixed,
Later tonight or this week.

BTW:  I will put in the functionality you requested in the message above as well.

Scott
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/