Hello Guest it is June 19, 2019, 11:51:26 AM

Author Topic: DROs randomly changing in Turn  (Read 2311 times)

0 Members and 1 Guest are viewing this topic.

DROs randomly changing in Turn
« on: July 17, 2013, 11:39:36 AM »
Hi All,

Proceeding slooooooowly up the learning curve with Turn, I have now arrived at the next problem which I am hoping someone will instantly point a finger at the solution....

Turn is installed at 066 (full licence) operating a Compact5 PC on a dedicated PC running XP SP3.

The problems seem to have materialised since I started using the tool tables.
I always start with a 'ref all' to move the carriage (with reference Tool no. 0) to my machine reference point, referenced with opto-switches.

The symptoms are that I use Turn with one of the turn wizards to carry out some piece of work and at some apparently random point, the X and Z axes change - not so far in mid program, but either after the end or when I have stopped the program in the middle to measure or to stop.

Is this a known bug somewhere?

Hoping that someone will know what my issue is, if not I will have to delve deeper into the apparently random nature of the problem.

Thanks in advance,

Simon

PS, I would have checked the bug list but "http://www.machsupport.com/knownbug.php" now terminates on the Newfangled site with a 404 error.

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: DROs randomly changing in Turn
« Reply #1 on: July 17, 2013, 04:39:38 PM »
Not something I could say I know the answer for as really it sounds like an offset is being called.
There are known issues with 066, especially with Turn and I wouyld definitely recommend you use an older version.
Hood
Re: DROs randomly changing in Turn
« Reply #2 on: July 20, 2013, 05:39:54 PM »
Hood,
Thanks for your response.

So far I have gone back to 062 with exactly the same results. Any suggestion which version might be be considered stable for turn?

Simon

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: DROs randomly changing in Turn
« Reply #3 on: July 21, 2013, 06:28:45 AM »
I use if I recall, 057.
However if you have the same issue with 062 then I  think it unlikely  it is a version dependant issue.
If you can post your xml, your Tools3.dat and the code you are having the issue with, I will take a look and see if I can replicate and hopefully find the issue.
Hood
Re: DROs randomly changing in Turn
« Reply #4 on: July 21, 2013, 07:16:13 AM »
Hood,
Thanks for your thoughts, I confirmed this morning that 057 had the same effect which seemed to appear at the end of running a wizard.
I appear to have traced the problem to the General Config page related to the actions at the end of a program - the tickbox in "remove all offsets" was set. Removing that seems to have cured the issue.
Simon

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: DROs randomly changing in Turn
« Reply #5 on: July 21, 2013, 07:24:52 AM »
Lots of settings in Mach that can do lots of things which you are not expecting or wonder why, the best thing to do in trying to solve a problem is try to find a repeatable way of it happening, looks like you found that way and thus found the answer to your problem :)

Hood