Hello Guest it is May 13, 2021, 09:20:19 PM

Author Topic: pwm bumped to minimum setting  (Read 18656 times)

0 Members and 1 Guest are viewing this topic.

Offline Tom

*
  •  15 15
    • View Profile
pwm bumped to minimum setting
« on: June 29, 2013, 03:00:39 PM »
Hi guys, I'm stuck..again on something...my cnc tries to run my gcode but just locks up. it gives me this status in mach3 :


"PWM bumped to minimum setting"

anyone know what that means?

Thanks!

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: pwm bumped to minimum setting
« Reply #1 on: June 29, 2013, 05:04:40 PM »
Do you have your spindle controlled from Mach and is it a PWM controlled spindle? If so you have your settings wrong, if not you have settings enabled that shouldnt be.
Hood

Offline Tom

*
  •  15 15
    • View Profile
Re: pwm bumped to minimum setting
« Reply #2 on: June 29, 2013, 05:31:54 PM »
Hi Hood, thanks for your help!

I only have a router which is not controlled by Mach. What do I need to change?

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: pwm bumped to minimum setting
« Reply #3 on: June 29, 2013, 07:45:25 PM »
Could be quite a few things but attach your xml and I will look.
Hood

Offline Tom

*
  •  15 15
    • View Profile
Re: pwm bumped to minimum setting
« Reply #4 on: June 29, 2013, 08:49:07 PM »
Sorry , I'm sure this is an stupid question, but what is the xml file and how would I find it for you?

Thanks again!

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: pwm bumped to minimum setting
« Reply #5 on: June 30, 2013, 03:39:22 AM »
Open Mach as normal and look lower right at the profile name. Close Mach then look in the mach3 folder on your computer for a file of that name with a .xml file extension. Right click and copy then go to your desktop and paste it then rename to something like Tom1.xml. Then on the reply page use the additional options button to browse to your desktop and attach the renamed file.
Hood

Offline ger21

*
  • *
  •  6,293 6,293
    • View Profile
    • The CNC Woodworker
Re: pwm bumped to minimum setting
« Reply #6 on: June 30, 2013, 08:25:01 AM »
Your g-code is probably specifying a spindle speed lower than the range of your pulley speed. Just changing your pulley speeds in Mach3 should get rid of that error message.

However, that message alone should not prevent Mach3 from running. My guess is that there may be some other errors in your g-code following the spindle speed?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Tom

*
  •  15 15
    • View Profile
Re: pwm bumped to minimum setting
« Reply #7 on: June 30, 2013, 09:00:59 AM »
Thanks for the explanation on the xml. I remember now getting this xml from the company who made the cnc , zenbot. I attached the file, thanks for taking a look!

I know this is something simple, that I just don't know enough to see. I had trouble with this exact thing about a month ago. I turned off the switch on my gecko that said Charge Pump, and suddenly I ran the code and it worked. I thought the problem was solved, but then i tried to run this code again and back to the same issue. I must have changed something else and misdiagnosed the solution.

My other files run fine still, its just this one...of course, the only one I really need to run.. and the most complex one I have tried. everything else i have done so far was basic shapes and easy stuff. I have so much to learn :)

I'll look for the pulley settings too!

Thank you again!!

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: pwm bumped to minimum setting
« Reply #8 on: July 01, 2013, 06:32:24 AM »
There is nothing in that xml that should stop your code from running, what spindle speed you have called may give you the PWM message however the file should still run.
If you attach your problematic code then maybe the problem can be found.

Hood

Offline Tom

*
  •  15 15
    • View Profile
Re: pwm bumped to minimum setting
« Reply #9 on: July 03, 2013, 09:34:53 AM »
I got it working, you will never guess what the problem was....

I just closed mach and restarted the program and it works fine now. Maybe it was because I turned the gecko drive on after I started mach the other times? I'm not sure, but as long as I start the gecko first, then boot up mach its great.

Thanks for the support and help you guys, even though the solution was strange I learned a lot more during this process so its all good.

Thanks again,

Tom