Hello Guest it is November 22, 2019, 03:04:24 PM

Author Topic: Adventures in Pokeys  (Read 22952 times)

0 Members and 1 Guest are viewing this topic.

Re: Adventures in Pokeys
« Reply #20 on: June 25, 2013, 08:40:56 AM »
Hi,
I've been so intent on building my control board that I haven't tried running code. I will do it today and let you know what happens. Maybe we can solve it together.
Ozzie
Re: Adventures in Pokeys
« Reply #21 on: June 25, 2013, 12:28:42 PM »
Just ran code with feeds of 5 and 15 ipm in it and the FRO worked fine, both increasing and decreasing.
From what little I know, check the last column on the first Mach 3 Pokeys setup screen. The column is labeled I/O. I have it set to input #1. That was the first I tried and it worked so maybe other settings work.
Then on the encoder page of the same setup, I have the encoder routed to OEM Dro 821.
What the encoder changes is the Feed Rate OVER-RIDE. It modifies the the feedrate by a percentage in both directions; under and over.
It sounds to me like somehow you have the encoder routed to the Feed RATE.
Hope this helps. Let me know, I need/want to learn all I can about this puppy.
Ozzie
Re: Adventures in Pokeys
« Reply #22 on: June 25, 2013, 02:40:57 PM »
have tried the direct mach3 config plugin screen setup...configuring the mpg2 to dro821....that would take over the code run.
BUT the one things that sounds differenet her is your IO setting...will have to try it later this evening

ptegler
Re: Adventures in Pokeys
« Reply #23 on: June 26, 2013, 06:22:38 AM »
...tried the input #1....made no difference. My MPG will control the DRO I set it to...but the gcode is not taking control as it should. so I went back to the original 1024 screen set and ran the full gambit of testing again.... no effect.

I also noticed the reset will not work when the MPG is mapped to the FRO %. I turn off the mapping and the reset will work and gcode sets the speed correctly.  :-(
Re: Adventures in Pokeys
« Reply #24 on: June 26, 2013, 08:56:26 AM »
Well, let's try the blind trying to lead the blind.
In my test yesterday the reset button worked as it should, even while the code was running.
I really became determined to find out what setting I had wrong when Matevz assured me that the software was working for others. I now assure you that it does work as you expect, you have some conflicting setting.
When I had a hard time trying to get mine to work, I kept thinking there was some setting in Mach 3 that had to be changed. But that is not true.
Since you keep referring to the encoder as an MPG, I'm wondering if you have MPG 2 turned on in Mach's native setup? If so, try turning it off. Undo any changes you made in Mach trying to make this work.
Getting this to work needs nothing but the Mach 3 Pokeys plug-in!
Ozzie
Re: Adventures in Pokeys
« Reply #25 on: June 26, 2013, 04:47:39 PM »
Ptegler,
I think you have a potentiometer connected, NOT an encoder!
Ozzie
Re: Adventures in Pokeys
« Reply #26 on: June 27, 2013, 06:24:46 AM »
not a potentometer...

I spend last evening even disconnecting the pokeys keyboard from the 66U...still no dice. The encoder(s) will take control of the DRO and not let the normal screen controls change them.  Turned on/off Input#1, #2,#3, #4 no differences.  T ook my main MPG that does work properly, and tried changing it to 821... same situation.
So I swapped back to the 1024 screen set as my blue steel set has a touchscreen and jogit pendant added in.... same issues. Whenever an encoder is mapped to the FRO override % DRO (821) or any of the FR related dros, the normal controls including reset do not work.

I also tested this entire sequence on the slow jog dro and the spindle speed dro.  Same thing happens.
The pokeys keyboard controls do not even continue to control the dro when an encoder vie the pokeys board is mapped to the fro.


I guess it's back to waiting to pokeys to finish this in the plugin as in the other thread   :-(
Re: Adventures in Pokeys
« Reply #27 on: June 27, 2013, 11:46:08 AM »
Yesterday, while doing some finish wiring on my controls, (mindless work), I was thinking about your problem. It occurred to me that everything you say is happening would happen if you connected a pot to the given Dro.
In the video of one member's new pendant, he points out using encoders for FRO and Spindle speed. So it works, it works for him, it works for me.
Since you are sure it is not a pot, I'm stuck.
I suggect that you rename the Mach 3 folder, then make a virgin installation of Mach 3. Don't modify anything in Mach 3. Install the Pokeys Mach 3 Plug-in. Disable all the Pokeys inputs except the two pins for the encoder.  Then try it.
Is the encoder you are using a simple 3 pin unit, or something more sophisticated? Mine is the former. Just like the diagram in the docs. Center pin to ground, outer two pins to two Pokeys inputs. If yours is not, you might try a simple one from Radio Shack.
Ozzie
Re: Adventures in Pokeys
« Reply #28 on: June 27, 2013, 05:39:25 PM »
....Just like the diagram in the docs. ??

ok... the following is  the ebay special I bought after giving up on the downfalls of using a potentiometer
The WTE version



BUT...I wired it up just like the 'test circuit' on the above linked data sheet so it operates just like and MPG. One V+, one ground, and two (A/B) output pins.
(even tested it as my main MPG, which worked fine)

Are you saying you simply wired it up as 'two switches to ground'  one pin to ground and the other two as individual inputs... hence you  Input Input#1 statements before
(were both set to input #1 or one to #1 and one to #2) ???
Re: Adventures in Pokeys
« Reply #29 on: June 27, 2013, 06:46:27 PM »
My encoder only has the three pins in a row.
I wired the center to ground on the Pokeys.
I wired the other two to pins, to 1 and 2 of the Pokeys.
On the Mach 3 Pokeys plugin go to encoder, select any encoder number, enable it, for channel A pick pin 1, channel B pin 2, then Dro 821. Return to first page and select input #1.
I'm doing this from memory. If it doesn't look right let me know and I'll go to the garage and make an exact record of the steps. That computer is not connected to the internet but I'll do it on a notepad.
Ozzie