Hello Guest it is December 09, 2019, 03:21:29 AM

Author Topic: Z probing not working on lset  (Read 1778 times)

0 Members and 1 Guest are viewing this topic.

Offline rasta

*
  •  29 29
    • View Profile
Z probing not working on lset
« on: May 21, 2013, 06:08:53 AM »
Hi; im in the process of modifying my micro lathe to cnc, everything works ok , except the automatic tool probing,
it works perfectly in x direction , but it does not work in the z direction, the machine works perfectly manually or automatic
so i think that the tool probing macro is the culprit.
can someone please help?
thank you
Mariano
 ;)

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Z probing not working on lset
« Reply #1 on: May 25, 2013, 08:09:39 PM »
Not great at VB but maybe if you attach your macro I can see something or possibly someone else who is better at VB will.
First thoughts may be it is looking for X and Y axis.
Hood

Offline rasta

*
  •  29 29
    • View Profile
Re: Z probing not working on lset
« Reply #2 on: May 27, 2013, 06:01:33 AM »
Hood; thanks for the prompt answer, the z axis probing works when i command the movement in mdi ( g33 z - .. ) and the axis stop as soon as the probe is touched,
I have to find out how to extract the macro from the screen button, ill keep you posted on this
regards
Mariano

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Z probing not working on lset
« Reply #3 on: May 27, 2013, 06:11:33 AM »
Operator menu the Edit Button Scripts. The button in question will be flashing and when you click on it the editor will open. Go to file menu then choose SaveAs option and you can save it to a different location with the name you wish, you can then attach it to the forum using the additional options button on the reply page.

From what you are saying regarding it working from MDI then it does sound like the macro is just  looking at X and Y moves only.
Hood