Hello Guest it is November 19, 2019, 12:16:59 AM

Author Topic: Printer port  (Read 2434 times)

0 Members and 1 Guest are viewing this topic.

Printer port
« on: May 19, 2013, 03:01:42 PM »
I downloaded Mach3 as instructed and did the reboot before using Mach3.  However, when I go to tune the axis Mach3 does not allow me to select the axis I wish to set.  Also when in the program option I cannot jog the axes.  I assume that the printer driver is not loaded in the computer.
The computer is a refurbished Dell OptiPlex Gx620 with windows 7.   Is there a driver I can download to fix this Problem?

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Printer port
« Reply #1 on: May 19, 2013, 03:06:42 PM »
Did you set up the ports and pins for the axis?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Printer port
« Reply #2 on: May 19, 2013, 07:29:58 PM »
Yes, the Port is set at 0x378.
The motor outputs are x=2. y=4, z-6
input signals are x=3, y-5, z=7

the Dir LowActive are all green as well as step low Active.
Step port and Dir Port are all set at one.

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Printer port
« Reply #3 on: May 19, 2013, 07:41:20 PM »
Are you using a 64 bit version of Windows 7? If so, The parallel port can't be used.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Printer port
« Reply #4 on: May 19, 2013, 07:58:07 PM »
No.  I double checked the specs and it is a 32 bit computer.
Re: Printer port
« Reply #5 on: May 23, 2013, 02:41:04 PM »
Make sure on the motor outputs tab you have checked the enable for the axis that you want to run.

Mike
We never have the time or money to do it right the first time, but we somehow manage to do it twice and then spend the money to get it right.