Hello Guest it is December 15, 2019, 07:02:25 PM

Author Topic: need direction home.  (Read 1640 times)

0 Members and 1 Guest are viewing this topic.

need direction home.
« on: May 06, 2013, 02:06:37 PM »
I am very frustrated at this point. i cant get my machine to find home and stay. i have two home switch installed but im trying to get one to work before i enable the other ones. i have a photoeye that breaks the beam when its home. i have set the input for pin 12 of port 1 . im using a Ethernet smooth stepper. this is what i have so far.

1. y home enable
2. denouncing set to 2000
3. when i trigger the switch. i can see it on the diagnostic page.
4. it is set to home in the neg

the problem is, when i ref all to home, or just try to home the one axle. the maching will move toward the switch. once it hits the switch, it revers direction and never stop. once it finds home, why wont it stay there?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: need direction home.
« Reply #1 on: May 06, 2013, 02:50:58 PM »
Debounce will have no effect with the ESS so no point in having anything there. Do you have a large filtering value in the ESS config for the home switch?
Hood
Re: need direction home.
« Reply #2 on: May 08, 2013, 07:53:01 PM »
where would i find that information?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: need direction home.
« Reply #3 on: May 09, 2013, 03:06:12 AM »
Plugin Control menu then ESS Config.
Hood