Hello Guest it is July 16, 2019, 11:13:39 PM

Author Topic: home limit switch problem  (Read 2423 times)

0 Members and 1 Guest are viewing this topic.

home limit switch problem
« on: April 14, 2013, 02:49:22 PM »
I know many people ask these types of questions and are referred to videos and search links.  But I've done my research and I'm still stuck.

Heres the issue.  The limit switch works fine.  I can see it in the diagnostics windows.  The Z home switch works just fine.  When I hit ref all , and the machine encounters the y axis switch, it hits the limit and stops instead of bouncing off and setting the home position.  Sometimes it will limit e-stop the system, sometimes it will go in the reverse direction after hitting the switch and keep going (ignoring all other switches and keeps going forever but slowly).   This is extremely frustrating. 

I am using the C10 breakout board with a smooth stepper running latest version of mach3.  I've set the debound to 8000 and doubling after every try all the way up to 640000.   The kernel is set for 100khz.   

What the heck is going on?  i'm extremely frustrated. what else can i try?  By the way the system is using an inductive switch found at cnc4pc and is set for active low.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: home limit switch problem
« Reply #1 on: April 14, 2013, 02:58:56 PM »
Debounce in Mach is not used when you are using an external device. You set the filtering in the plugin, dont set it high though, try the lowest, 1.43 and increase by that amount each time until the issue is solved. If however you are not solved by 10 or so then you have serious noise issues and putting more in will just cause you problems.
Hood
Re: home limit switch problem
« Reply #2 on: April 14, 2013, 03:05:08 PM »
I don't understand what you mean by external device.  Mach is a software.  Everything is external is it not?  And what plugin am I looking for?

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: home limit switch problem
« Reply #3 on: April 14, 2013, 03:06:24 PM »
You are using a SmoothStepper, it is an external motion controller, in other words you are using Mach but not the Mach3 parallel port driver, you are using an external device instead.
Hood
Re: home limit switch problem
« Reply #4 on: April 14, 2013, 03:08:32 PM »
ahh that makes sense.  Let me try that and i'll report back. thanks.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: home limit switch problem
« Reply #5 on: April 14, 2013, 03:11:04 PM »
Sorry never answered you other part, you will find the filtering from Plugin Control menu then Smoothstepper ...... config

Hood
Re: home limit switch problem
« Reply #6 on: April 14, 2013, 04:20:30 PM »
U are the best hood.  It was the noise settings in smooth stepper that did the trick.  I woulda never even thought of looking there.  My home works perfectly now.  Its amazing how nice having a home switch is.  I've been running without for a while and was just using the internal switches with turbotaig.  Its way nicer thru mach3.  

I gotta say, mach3 is the best money i ever spent.  

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: home limit switch problem
« Reply #7 on: April 14, 2013, 04:49:36 PM »
Good you are sorted :)
And yes Mach is very keenly priced :)
Hood