Hello Guest it is August 19, 2019, 02:32:20 AM

Author Topic: Mach 3 motor tuning  (Read 5765 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 motor tuning
« on: April 11, 2013, 03:02:32 PM »
This is my first post! Finally have and issue i cannot get around.

So i have been trying to test the accuracy on my X3 cnc conversion and i am running into a strange issue. with a dial indicator, if i move in the -x direction .100", each time it jogs the indicator goes back to 0... cool. Now if I move .100 in the x+ direction the first move goes to zero and each move after that in the same direction keeps adding .001 so it is .005 after 5 moves. The weird thing is when i change direction back, instead of going to .005 it goes back to zero!! And if i keep going in the same direction.. it goes back to zero every time!

Any thoughts??

Thanks!

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 motor tuning
« Reply #1 on: April 12, 2013, 03:07:30 AM »
Can you attach your xml please.
Hood
Re: Mach 3 motor tuning
« Reply #2 on: April 12, 2013, 08:26:58 AM »
here you are

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 motor tuning
« Reply #3 on: April 12, 2013, 02:03:04 PM »
Ok go to config menu then Backlash and disable it and see if it helps, sounds to me like you may have over compensated the amount of backlash you have.
Hood
Re: Mach 3 motor tuning
« Reply #4 on: April 12, 2013, 03:14:52 PM »
i tried that and it didnt seem to make a difference.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 motor tuning
« Reply #5 on: April 12, 2013, 03:18:42 PM »
Ok keep the backlash disabled, at least for the time being. Change your active state of the step pin for the problematic axis and see if that helps.
Hood
Re: Mach 3 motor tuning
« Reply #6 on: April 12, 2013, 03:20:31 PM »
Hood, could you clarify how to do that?

Also my jog is now going really slow no matter if i change the feed rate or not.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 motor tuning
« Reply #7 on: April 12, 2013, 03:25:40 PM »
Ok jog is because you have it set to Step Jog rather than continuous, to change press the Tab Key on your keyboard then in the screen that pops up press the Jog Mode button untill it is at continuous.

To change the active setting of the step pin go to Config menu then Ports and Pins the Motor Outputs and put a tick in the Step  Low Active box for the X axis.
Hood
Re: Mach 3 motor tuning
« Reply #8 on: April 12, 2013, 03:30:09 PM »
I switch between Step and Cont all the time so its not that. In cont mode it is jogging really slow how ever is was fine earlier today.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 motor tuning
« Reply #9 on: April 12, 2013, 03:32:19 PM »
Ok have you got the Slow Jog set to a low %. The xml you attached has it in step mode and 100% but that has possibly been changed since you attached it?
Hood