Hello Guest it is May 23, 2019, 03:21:15 AM

Author Topic: Puzzle me this.  (Read 3450 times)

0 Members and 1 Guest are viewing this topic.

Puzzle me this.
« on: March 30, 2013, 10:58:44 PM »
So, I opened up Mach3Screen, double clicked Rev All-Home and added Code("x0y0z0") to the end of the normal sequence of:
DoButton( 24 )
DoButton( 23 )
DoButton( 22 ).

The hope was to get the machine to move to 0,0,0 from the Home Offsets.
It does the DoButton sequence then stops.  If I Ref All-Home again,THEN it does the x0y0z0.  THEN, it proceeds to do the DoButton sequence again.

So, I changed it to:

DoButton( 24 )
Code("z0")
DoButton( 23 )
Code("y0")
DoButton( 22 )
Code("x0")

Again, it does something very similar.  It completes the Dobutton's the first time its selected putting in the offset values.  Then it zero's x, y, z the second time it's selected, then goes through the DoButton sequence again.

The net result being, that I'm always left at the Home Offsets and never at 0,0,0.

How can I get it to move to 0,0,0 after doing a Ref All-Home?

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Puzzle me this.
« Reply #1 on: March 31, 2013, 05:15:18 AM »
Sounds to me like you may be using ver 066 or 067 of Mach, if you are then go back to an earlier version as these versions have issues, one of which you have just found.

Hood

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Puzzle me this.
« Reply #2 on: March 31, 2013, 05:17:32 AM »
Oh and BTW you should have a G0 in there as well or if wanting at a feedrate then a G1 with an F**

Hood
Re: Puzzle me this.
« Reply #3 on: March 31, 2013, 12:20:12 PM »
Thanks Hood,
It's version 3.042.029 dated 10/6/09.
Can you suggest a version that will do this move?
I assume I'd need to do a full Uninstall/Install.  Would my existing xml file be compatible?
As far as the feed rate goes, I'm only moving about a 100 thou so I just let it run at the default 5 ipm.

Offline BR549

*
  •  6,865 6,865
    • View Profile
Re: Puzzle me this.
« Reply #4 on: March 31, 2013, 12:44:16 PM »
You may want to try it this way. I am assuming that you have Home offsets in place to indicate where you want Machine 0,0,0 to be with the G28 function

DoButton( 24 )
While Ismoving()
Wend
DoButton( 23 )
While IsMoving()
Wend
DoButton( 22 )
While Ismoving()
Wend

Code" G28 "
While Ismoving()
Wend

Code"G92 X0 Y0 Z0"  'Sets user X0Y0Z0

END
« Last Edit: March 31, 2013, 12:51:43 PM by BR549 »
Re: Puzzle me this.
« Reply #5 on: March 31, 2013, 04:01:52 PM »
Strangely enough, it worked exactly once.  I pushed the button and it did exactly what I wanted.  I pushed it again and it did the backwards thing and once again came to rest at the offsets.  I closed the program, re-opened it and tried again. No joy.  Definitely seems to be a bug but it's a really strange one.

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Puzzle me this.
« Reply #6 on: March 31, 2013, 05:04:31 PM »
Ok I should have realised it wasnt a later version when you said Mach3Screen.
If you attach your xml I will test it out here.
Hood
Re: Puzzle me this.
« Reply #7 on: March 31, 2013, 07:25:17 PM »
Here you go.

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Puzzle me this.
« Reply #8 on: April 01, 2013, 03:01:09 AM »
Ok working fine here with Ver 057 that I have loaded, below is what I put in the button.

DoButton( 24 )
DoButton( 23 )
DoButton( 22 )
DoButton( 25)
While IsMoving()
Wend
Code"G0X0Y0Z0"

If it doesnt work with that let me know and I will test with the version you have.

Hood
Re: Puzzle me this.
« Reply #9 on: April 01, 2013, 12:52:49 PM »
I'm not sure what I was doing wrong before but that works just like I originally planned.

Thanks Hood.