Hello Guest it is November 20, 2019, 04:47:04 PM

Author Topic: Spindle runs in Parallel mode OK but not in ESS ?  (Read 11653 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Spindle runs in Parallel mode OK but not in ESS ?
« Reply #20 on: March 27, 2013, 05:09:10 PM »
Your xml doesnt have any spindle settings in the ESS plugin, see screensot, no pulse width here but then that is likely because its set to relay or none.
Hood

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Spindle runs in Parallel mode OK but not in ESS ?
« Reply #21 on: March 27, 2013, 05:16:41 PM »
The xml should contain all the settings you have entered, even ESS ones. That is of course as long as you have shut Mach down after making the changes as that is the only time the data actually gets saved to the xml.
Hood
Re: Spindle runs in Parallel mode OK but not in ESS ?
« Reply #22 on: March 27, 2013, 05:48:29 PM »
The xml should contain all the settings you have entered, even ESS ones. That is of course as long as you have shut Mach down after making the changes as that is the only time the data actually gets saved to the xml.
Hood

Yes, Mach was shut down and re-opened each and every time I made any changes, done it so many times it is habit now :)

From your observations and my own testing it looks as though it must be that the ESS Plugin is not writing the changes to the XML properly, I`ll do some more testing of making changes in the ESS Plugin and double check what is or is not being written into the XML, would I be correct in thinking that if it isn`t writing correctly to the XML then it probably isn`t writing to the ESS card properly either ???

Regards
Rob

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Spindle runs in Parallel mode OK but not in ESS ?
« Reply #23 on: March 27, 2013, 06:01:49 PM »
You would really have to ask Greg about that but any time I have checked someones xml or looked at my own it reflects the settings they have.
Hood
Re: Spindle runs in Parallel mode OK but not in ESS ?
« Reply #24 on: March 27, 2013, 07:32:45 PM »
You would really have to ask Greg about that but any time I have checked someones xml or looked at my own it reflects the settings they have.
Hood

Hmmm, I have looked at the XML again, not well up on what I should be looking at/for but it does seem to me that the changes are there after all !!

The spindle does look to be in step/direction mode, see attached image, it a screen grab of the file I uploaded that I just opened in IE and it looks right to me ???

Regards
Rob

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Spindle runs in Parallel mode OK but not in ESS ?
« Reply #25 on: March 27, 2013, 07:39:52 PM »
Ok just wondering, where are you setting Step/Dir spindle mode and also pulse width?
Hood
Re: Spindle runs in Parallel mode OK but not in ESS ?
« Reply #26 on: March 27, 2013, 08:35:36 PM »
Ok just wondering, where are you setting Step/Dir spindle mode and also pulse width?
Hood

Usual Mach3 setup regarding spindle step/dir under "Ports & Pins" plus having to set again both the mode and pulse width in the ESS Plugin, no other settings in the plugin, it is very odd for sure, I ran a program on a small mould today at the 2200rpm for 4 hours 22 minutes, ran faultlessly. When it was finished I changed the spindle speed to 3000rpm and it went to "E Stop condition" in just 26 seconds ???

I have sent a copy of the XML to Greg for his perusal, just waiting to hear back from him  ;D  ;D

Regards
Rob

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Spindle runs in Parallel mode OK but not in ESS ?
« Reply #27 on: March 27, 2013, 08:38:45 PM »
You dont set step/dir in the spindle options in Mach, you do it in the ESS plugin. The Pulse Width on motor tuning page is not used by the ESS, you need to set that in the plugin.
If you do that and it is not sticking then there is definitely a problem.
Hood
Re: Spindle runs in Parallel mode OK but not in ESS ?
« Reply #28 on: March 27, 2013, 08:50:05 PM »
You dont set step/dir in the spindle options in Mach, you do it in the ESS plugin. The Pulse Width on motor tuning page is not used by the ESS, you need to set that in the plugin.
If you do that and it is not sticking then there is definitely a problem.
Hood

The step/dir option is set in the ESS Plugin as is the Pulse Width, if the settings in Mach are ignored by the ESS then it shouldn`t matter what they are set to yes ? ?

I do have them set both the same anyway so there shouldn`t be a problem, as I see it there is no way to not have any spindle settings in Mach unless I disable that by checking the "Relay" checkbox yes ? ?

Regards
Rob

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Spindle runs in Parallel mode OK but not in ESS ?
« Reply #29 on: March 28, 2013, 03:51:00 AM »
Thats correct, settings in Mach are ignored. I am wodering why I do not see that you have them set in the xml, could be just I have an older plugin but I still think thats unlikely.
Do they stick for you? ie if you set them and restart Mach then go back into the plugin config are they still set?
Hood