Hello Guest it is November 22, 2019, 08:13:40 PM

Author Topic: Motors locking when not in MPG screen???  (Read 5049 times)

0 Members and 1 Guest are viewing this topic.

Motors locking when not in MPG screen???
« on: March 20, 2013, 06:25:07 AM »
Hi Guy's

 Another Newbie question can't seem to find any answers to it so thought i'd ask,

 When operating my motors in rapid speed by holding the shift key I get a constant locking of motors even when running a G-Code, but in motor tuning I can run them as fast as I want without any motor lock up's at all  ??? .

 When I'm back in the main Mach3 screen and press the ALT key to bring up the MPG screen and try operating motors at rapid speed again by pressing the SHIFT key all the motors work perfect no locking at all and I can run a G-Code without a problem as fast as it can go  ??? .

 If anyone has come across this problem I would love to know how you fixed it.

 Thanks
 Shane.

 4 x Nema23 300Oz
 Gecko G540
 48v 7.3A PSU
 Mach3

Online Chaoticone

*
  • *
  •  5,631 5,631
  • Precision Chaos
    • View Profile
Re: Motors locking when not in MPG screen???
« Reply #1 on: March 20, 2013, 09:59:23 AM »
Welcome to the forum Shane!  Not sure what you have going on unless your motors tuneing is just way high.  Do you have backlash comp enabled?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Motors locking when not in MPG screen???
« Reply #2 on: March 20, 2013, 05:13:02 PM »
Hi Brett,

I'm not sure, as I haven't had a great deal to do with the Mach3 program have WASTED a lot of time on those TB6560 drivers  >:(

Could you point me in the direction as to where that setting is please.

Thanks
Shane.

Online Chaoticone

*
  • *
  •  5,631 5,631
  • Precision Chaos
    • View Profile
Re: Motors locking when not in MPG screen???
« Reply #3 on: March 20, 2013, 05:19:18 PM »
The motor tuning is in config., motor tuning and backlash comp is in config., Backlash.  Just be sure that the Backlash Enabled tick box does not have a check in it.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Motors locking when not in MPG screen???
« Reply #4 on: March 20, 2013, 05:21:39 PM »
OK, Thanks will check it out and let you know how it goes.

Shane

Offline ger21

*
  • *
  •  6,289 6,289
    • View Profile
    • The CNC Woodworker
Re: Motors locking when not in MPG screen???
« Reply #5 on: March 20, 2013, 05:36:36 PM »
Try turning off the toolpath display and see if it helps. If your PC is marginal, the toolpath display can use a lot of resources.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Motors locking when not in MPG screen???
« Reply #6 on: March 20, 2013, 05:48:18 PM »
Hi Gerry,

I think you might be onto something there because when I move the MPG screen off the tool display motors lock up again and when I cover the tool display with the MPG screen again motors run perfect.
Could you tell me where i turn that off please.

Thanks
Shane
Re: Motors locking when not in MPG screen???
« Reply #7 on: March 20, 2013, 05:52:35 PM »
I checked the backlash settings and the enable box does not have a tick in it.

Looks like it might be my computer..

Online Chaoticone

*
  • *
  •  5,631 5,631
  • Precision Chaos
    • View Profile
Re: Motors locking when not in MPG screen???
« Reply #8 on: March 20, 2013, 06:06:05 PM »
On the diagnostics page, above the reset button.  Toolpath on/off button.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Motors locking when not in MPG screen???
« Reply #9 on: March 20, 2013, 06:16:23 PM »
Thanks again Brett, I will try that.

Shane