Hello Guest it is July 05, 2020, 11:47:44 PM

Author Topic: Mach jogging got disabled, how do I get it going again?  (Read 4635 times)

0 Members and 1 Guest are viewing this topic.

Mach jogging got disabled, how do I get it going again?
« on: March 14, 2013, 08:01:37 PM »
I'm bringing up a Mach3 driven lathe using the 057 version. Thanks to some help from the nice guy at PMDX (real nice breakout boards) I've got it 98% working, axis drives are working well, MPG is working on X and Z, spindle speed/direction control is working, E stop and charge pump are working.

I'm using a joy stick connected to an IPAC with keygrabber to generate key codes to do the jogging.

This was actually the first thing I set up and it was working fine at first.

But something I've done in the following setup caused the jogging to stop working. I've double (and triple) checked that keygrabber is seeing the joy stick switch closes and is sending out the correct key codes and they are the ones set in the Mach hotkey config menu.

Also its set to Continous jog and the jog rate has a non-zero number. But no jogging occurs (no change in the axis DRO's either).

Is there some other Mach setting I could have accidentally changed when setting up the other stuff that could have disabled the jogging?

Thanks,

Paul T.
Re: Mach jogging got disabled, how do I get it going again?
« Reply #1 on: March 14, 2013, 08:35:22 PM »
I've been going thru all the settings and still can't figure out why jogging stopped working.

If anybody is willing to take a look to see what I've done wrong I've attached my .xml file.

Thanks,

Paul T.
Re: Mach jogging got disabled, how do I get it going again?
« Reply #2 on: March 14, 2013, 10:16:41 PM »
just a thought, try hitting "<alt> J" see if that helps

John

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: Mach jogging got disabled, how do I get it going again?
« Reply #3 on: March 15, 2013, 08:40:15 AM »
Paul, you must also be on a screen that has a jog enabled led.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Mach jogging got disabled, how do I get it going again?
« Reply #4 on: March 17, 2013, 07:12:15 PM »
My screen has a jog enabled LED and its definitely on.

Dinking around I discovered that in addition to the Hot Key based jogging there are OEM button values, 307 and up, that also do jogging.

After making some buttons for those values jogging worked with them and so I assigned my hotkeys to "push" those buttons.

I still can't figure out why the standard HotKey based jogging won't work, even running without keygrabber, just straight from the keyboard with the standard hotkey vals.

It was working early on for me but something got it in a bad state and Hotkey based jogging just won't work any more. Oh well, I got it working with the button approach.

Paul T.

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: Mach jogging got disabled, how do I get it going again?
« Reply #5 on: March 17, 2013, 07:28:40 PM »
Paul, you arent useing the number/arrow keys and turned your Num lock on or something did you?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Mach jogging got disabled, how do I get it going again?
« Reply #6 on: March 17, 2013, 07:37:09 PM »
No, its not a numlock issue, I've tried both the default hotkey's and reassigned ones.

Something strange is going on, perhaps its a bug in the 057 version I'm using but I've got the jogging with the extra buttons so I'm going to let the hotkey problem slide for now.

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: Mach jogging got disabled, how do I get it going again?
« Reply #7 on: March 17, 2013, 07:55:04 PM »
OK, if you get a chance, post your xml and screen set your running.  I'd like to see if I can figure out whats going on with it.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach jogging got disabled, how do I get it going again?
« Reply #8 on: March 18, 2013, 03:55:30 AM »
In your xml you have the jog keys set to non standard Hotkeys, could that be your problem?
Hood
Re: Mach jogging got disabled, how do I get it going again?
« Reply #9 on: March 21, 2013, 03:04:56 PM »
I discovered my jogging didn't work on a wizard I made after I moved the jogging buttons to the persistant (0) screen using Machscreen.
It drove me nuts until I read this post and moved the jog buttons back to each screen. Now it works fine.
Rich