Hello Guest it is November 29, 2021, 08:01:34 PM

Author Topic: Mach3 adding extra loops in a string of arcs  (Read 9770 times)

0 Members and 1 Guest are viewing this topic.

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: Mach3 adding extra loops in a string of arcs
« Reply #10 on: February 16, 2013, 09:14:08 AM »
Hiya Tweakie, you must not have tool  #4 set in your tool table. He is using tool comp. You should be seeing the OFFSET toolpath as well.
Set tool#4 to .125" diam.

(;-)TP









Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Mach3 adding extra loops in a string of arcs
« Reply #11 on: February 16, 2013, 12:17:25 PM »
just for the hell of it try cam'ing this dxf and see what occurs.

Ian

Offline Deano

*
  •  15 15
    • View Profile
Re: Mach3 adding extra loops in a string of arcs
« Reply #12 on: February 16, 2013, 12:40:10 PM »
Thanks, BR549, I tried loading the latest rev of Mach 3, and ran the part (cutting air). It seemed to be fine, then I noticed I hadn't defined the tool 4 dia. After setting that to .125 dia. it was back to the same problem.
Tweakie, I attached a better screen shot, deleted most of the code so the portion of interest is larger so you can see the extra moves.  Looks like Mach is thinking each arc segment needs a lead-in move.  But why only these few segments and not the rest of the part outline?
Before the original post I tried several times re-drawing the arcs slightly different and re-posting the code. no change.
Will a Fanuc post processor work better? maybe I'll try that after the grandkids go home today.

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: Mach3 adding extra loops in a string of arcs
« Reply #13 on: February 16, 2013, 12:47:06 PM »
HIYA IAN , Tried that as well IF you cut the outside profile CCW (Climb)it works (mostly G2's) If you cut it CW(Conv) (mostly G3's) it fails.

even tried moving the Leadins around and doing leadin/out on each section (as it should be done) same thing.

There be GLITCHES  in TC (;-) 

(;-) TP

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Mach3 adding extra loops in a string of arcs
« Reply #14 on: February 16, 2013, 01:02:14 PM »
Terry - phew! - I thought I'd turned invisible for a minute there!!!

Did you try the .dxf I posted?

Ian

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: Mach3 adding extra loops in a string of arcs
« Reply #15 on: February 16, 2013, 04:22:31 PM »
HIYA Ian, Yes I did. As draw it will not cam correctly. The outer contour leadin/out lines overlap the contour lines The cam does not know what you were intending to do. I fixed the leadin/outs BUT it still will not cut correctly as a Climb milling. Turn the direction around to Conv milling and it profiles correctly every time.

I even tried taking OUT the drawn leadin/outs and let the CAM apply them, same problem.

Here is an example of the Glitchs in the offsetting AND "this" is as good as it has been, and can be a lot worse.

(;-) TP
« Last Edit: February 16, 2013, 04:25:32 PM by BR549 »

Offline Tweakie.CNC

*
  • *
  •  8,863 8,863
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach3 adding extra loops in a string of arcs
« Reply #16 on: February 17, 2013, 04:11:11 AM »
Hi Guys,

Thanks for taking the time to explain the problem to a dumbo – finally I understand (or at least I think I do).

I fully appreciate that this is not the answer to the problem but for me the solution would be to CAM the tool radius offset profiles and leads (the downside is the cost of the CAD/CAM software, if you don’t already have it).

Tweakie.

KEEP SAFE !

Offline RICH

*
  • *
  •  7,419 7,419
    • View Profile
Re: Mach3 adding extra loops in a string of arcs
« Reply #17 on: February 17, 2013, 05:46:13 AM »
Hey Tweakie,
Don't feel bad as i had the same problem when monitoring this thread.
Also agree that using a low cost CAM program solves the issue for doing the work but dosen't address the quirk in Mach.

RICH

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: Mach3 adding extra loops in a string of arcs
« Reply #18 on: February 17, 2013, 10:56:54 AM »
IAN, overlaped the contour line was NOT the correct explantion. THe lines CROSSED over the contour line and stopped on the far side of the line. The Cam saw it as a seperate entity not as a leadin/out

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: Mach3 adding extra loops in a string of arcs
« Reply #19 on: February 17, 2013, 11:03:36 AM »
HIYA Tweaky, In the general scheme of things I agree that most can use the Standard CAM offsetting. BUT in the Part machining world where precision is required then TOOL COMP is preferred. You need to be able to adjust the TC to make the part to precise dimensions.

With Cam comped code you have no choice on precision you get what you get and there is no way to adjust the final dimension OTHER than RECAMing the part again and possibly having to cut a new part .

In the ART world "Cam" is king(;-)

Just a thought, (;-) TP