Hello Guest it is July 07, 2020, 12:09:09 AM

Author Topic: Homing Issue on X-axis Only  (Read 1839 times)

0 Members and 1 Guest are viewing this topic.

Homing Issue on X-axis Only
« on: February 06, 2013, 11:29:45 AM »
I have a CNC router that I recently replaced the breakout board to a cnc4pc
C11G. I was setting up Mach3, and everything seems to work just fine except for
when I home the axes. The Y and Z home perfectly fine. They trigger the
proximity switches and back off, but the X axis triggers it's switch and doesn't
back off. It just stops at the switch and keeps it triggered.

Then I have to Reset, then toggle the active switches, move the X-axis, it
triggers the proximity switch again, reset, toggle active switches, and then I
can move the X-axis freely.

I also have all the axes set with Auto Zero enabled, and that doesn't seem to
work either.

Any ideas?

Thanks,
Matt

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: Homing Issue on X-axis Only
« Reply #1 on: February 06, 2013, 11:35:01 AM »
What version of Mach are you running?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Homing Issue on X-axis Only
« Reply #2 on: February 06, 2013, 11:41:37 AM »
Version R3.043.066
Re: Homing Issue on X-axis Only
« Reply #3 on: February 06, 2013, 11:54:25 AM »
Okay, I've been going through the setting some more, and it appears that the EStop is set to the same pin as the X-Axis home switch.

I thought I disabled it before, but I guess you can't.

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: Homing Issue on X-axis Only
« Reply #4 on: February 06, 2013, 12:04:11 PM »
 :)  You can't disable estop.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!