Hello Guest it is August 20, 2019, 05:47:16 PM

Author Topic: Bugy Mach crashed my machine  (Read 3954 times)

0 Members and 1 Guest are viewing this topic.

Bugy Mach crashed my machine
« on: February 04, 2013, 12:48:41 PM »
Hi,
the softkey-function is very bugy.
I have installed Mach 3 on several computers, and most times the softkeys works well. If i press the keyboard, the machine moves, and if take the finger from the buttom it stopped, but sometimes if i release the buttom, the machine does not stopp and runs into the end-Switch.
Today the ********* happens, i have a 16mm running cutter in the machine and was posiitioning it with single step and keyboard  1mm down after the other, and then the error occurs and the machine goes into continious run, and the cutter runs through my t-grooved-pate and now there is a big hole in it.
I have tested different releases of mach 3 and the error appears on all. Should it be possible, that i was the first with this bug?
My nice new machine has no an ugly hole it it, *********, my eye is burning if i see it.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Bugy Mach crashed my machine
« Reply #1 on: February 04, 2013, 02:00:32 PM »
Can you attach your xml please.
Hood
Re: Bugy Mach crashed my machine
« Reply #2 on: February 04, 2013, 03:34:56 PM »
Hi here is the file
I have German version

No i have deleted all, installed the last beta from this page, make a new profile with configuration,
and the next problem comes up.
Homing does only work on z-axis, y und x does not run by clicking on homing, manual i can move them...

I see someone has the same problem with homing and ESS
http://www.machsupport.com/forum/index.php/topic,23255.0.html
but if i reinstall, it does not work
« Last Edit: February 07, 2013, 03:24:22 PM by Chaoticone »

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Bugy Mach crashed my machine
« Reply #3 on: February 04, 2013, 04:21:21 PM »
Probably best to ask on the SmoothStepper section of the forum.
Hood
Re: Bugy Mach crashed my machine
« Reply #4 on: February 05, 2013, 01:37:29 AM »
Problems are the same on LPT...

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Bugy Mach crashed my machine
« Reply #5 on: February 05, 2013, 02:52:41 AM »
Load a standard screenset and see if there is still a problem.
Hood
Re: Bugy Mach crashed my machine
« Reply #6 on: February 05, 2013, 02:45:56 PM »
Hello, i have installed an older Version of Mach 3 and homing does work.
If i install the last beta or last lockdown, homing only works on z-axis.

I think there is a big problem in the german version of mach 3 from cnc-winckler, because i get somtimes errors in homing. there comes a popup with error in a variable twice times, and if i don't stop the machine manually and click ok on the errors, homing does not work and the machine is slowly homing in the wrong direction. Hi has modified homing with a second move with präcission homing. There are other errors with soft limits. If it is on, i have problems with homing, because the reference key is behind soft limit.

I think there is a problem with his version, i think he has a nice screen, but if it does not work, i can not use.
The original mach 3 homing and softlimits and the movement with the keys works, but i have two problems in the moment.


Why does homing not work on all axis with the latest versions?

I can not get my spindle run. I think i have configured in the english version the same values like in german, but it does not run. I  use pwm and my tripple beast converted it to a voltage between 1 till 10 volts, but there seems to be something wrong

What is dwell?

Thanks

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Bugy Mach crashed my machine
« Reply #7 on: February 06, 2013, 03:02:17 AM »
Adraid I do not know anything about your setup regards PWM, dont even know what spindle speed controller you are using, thus unable to say why it is not working.

Dwell is basically a delay, it really depends what you are meaning by dwell as to what exactly it impacts on, for example if it is with regards to spindle then it means when you turn on the spindle Mach will wait for the specified time before it continues.
Hood
Re: Bugy Mach crashed my machine
« Reply #8 on: February 06, 2013, 07:53:47 AM »
Hello,
yesterday i have tested again.
With Mach R3.043.22 Homing works on all axis.
With R3.043.66 and R3.043.67 new installed, only z-axis works by homing.
If i install first R3.043.22 and then R3.043.66 over it an use the mill.xml i create under R3.043.22, homing works too.
I have no explanation for this.

My spindle is a Elte 2,2KW and i have a tripple beast controller.
I need only a PWM-signal on a pi, and my tripple beast creates a voltage dc on it should work, but the PWM is not on the pin of LPT, This is my problem with the originaly Mach3, in the german version it works.

Offline Chaoticone

*
  • *
  •  5,570 5,570
  • Precision Chaos
    • View Profile
Re: Bugy Mach crashed my machine
« Reply #9 on: February 06, 2013, 12:20:46 PM »
There is a possible problem with homeing in later versions.  They are looking at it and will hopefuly have something in a few days.  If it's doing good for you now, that's good.  If not, you may want to stick to an earlier version.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!