Hello Guest it is June 26, 2019, 07:06:09 PM

Author Topic: W2000 & Mach?  (Read 5863 times)

0 Members and 1 Guest are viewing this topic.

W2000 & Mach?
« on: January 19, 2013, 12:12:04 PM »
I noticed the splash screen when Mach starts loading says "CNC Controller for Windows XP & 2000."  I just took an old Dell small case P4 900 with W2000 Pro out of service and was wondering if it'd run Mach well enough to control an old, slow MicroMill I have.  It has 80 in/oz steppers and goes maybe 12-15 IPM on a good day so speed isn't a big factor. ;)

The small form factor Dell box is just right to fit nicely in the available area.  Reckon 2000 would work OK or should I wipe it clean and throw XP on it?
Milton from Tennessee ya'll.
Re: W2000 & Mach?
« Reply #1 on: January 19, 2013, 12:25:51 PM »
I ran my machines for years on an ancient 540MHz/512KB machine.  Never had a single problem that could be tied to PC performance.  The only way to know if it'll work is to try it.

Regards,
Ray L.
Regards,
Ray L.

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: W2000 & Mach?
« Reply #2 on: January 19, 2013, 02:20:16 PM »
2000 works well as does XP, later versions of Windows I have not liked, so never used. 2000 takes less resources than XP so is probably a better choice on a lower end computer.
Test your Dell by installing Mach and doing the driver test, if it has a nice smooth line with no spikes then it should work well. If it doesnt then you could always get one of the external controllers available.
Hood
Re: W2000 & Mach?
« Reply #3 on: January 19, 2013, 05:17:07 PM »
Awesome!  Thanks gentlemen, I'll do the driver test and see how it goes.

I forgot that it has integrated video so I'll need to look around in the graveyard for a video card that'll fit.  At least I don't have to worry about a parallel port on the old girl.:)
Milton from Tennessee ya'll.

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: W2000 & Mach?
« Reply #4 on: January 19, 2013, 05:27:21 PM »
It may be fine with integrated video, just depends, some are ok some not. One thing however is I have seen mention that some Dells with integrated video do not work well at all even when using an external video card. You will likely see if that is the case however as you will see blips in the driver test every so often.
Hood
Re: W2000 & Mach?
« Reply #5 on: January 19, 2013, 09:53:41 PM »
Hmmm, took a while but finally got the ol' gal up & running after supper with a fresh W2000 install.  Installed Mach fine but the driver test shows some spikes every so often with max variation in the low 20's with the occasional spike up to 29 uS.  Waste of time going any further with it?

I didn't find a separate video card yet...d'ya think one would help or is it probably just a Dell m/board issue?
Milton from Tennessee ya'll.

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: W2000 & Mach?
« Reply #6 on: January 19, 2013, 10:35:50 PM »
Hard to say, seems Dells can be problematic, I am sure it was Rich that tried just about everything to make one work but couldnt so had to go with a Smoothstepper to get it working.
If you find a card lying around give it a try, if you have to buy one to try then I would say its probably not worth spending money as it may not work.
Hood
Re: W2000 & Mach?
« Reply #7 on: January 20, 2013, 12:44:05 PM »
Well cr@p!  I copied over my license file and the 2 .xml's from the PC that works well with the ORAC and the MicroMill but for some reason the W2000 box won't work with either of them.  Anything else come to mind I should have done?
Milton from Tennessee ya'll.

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: W2000 & Mach?
« Reply #8 on: January 20, 2013, 12:48:46 PM »
You have the correct port assigned?
Hood
Re: W2000 & Mach?
« Reply #9 on: January 20, 2013, 12:56:39 PM »
Thanks Hood, I'm looking at that sort of stuff right now.  I thought it was an E-stop config thing but it wasn't.
Milton from Tennessee ya'll.