Hello Guest it is June 02, 2020, 04:50:44 PM

Author Topic: Need help - Machine going nutz!!  (Read 7296 times)

0 Members and 1 Guest are viewing this topic.

Need help - Machine going nutz!!
« on: January 13, 2013, 12:10:08 PM »
I purchase my license and copied it to mach 3 folder, rebooted and now my y axis ( i have 2 motors - one reversed) are now going opposite of each other causing it to twist and my x axis only goes left now???????

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Need help - Machine going nutz!!
« Reply #1 on: January 13, 2013, 12:43:48 PM »
Change the Dir active state of one of them.
As for X only going one way sounds like possibly a wiring issue.
Puting a licence in the folder will not do any of the changes you have seen.
Hood
Re: Need help - Machine going nutz!!
« Reply #2 on: January 13, 2013, 01:04:29 PM »
that didnt work.  and the wiring is good.  nothing changed

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Need help - Machine going nutz!!
« Reply #3 on: January 13, 2013, 01:13:45 PM »
Did you open the correct profile? Are the ports and pins set correct?
Hood
Re: Need help - Machine going nutz!!
« Reply #4 on: January 13, 2013, 01:28:49 PM »
i only have one file and yes, pins and ports are correct
Re: Need help - Machine going nutz!!
« Reply #5 on: January 13, 2013, 01:31:01 PM »
problem,  if i go down on the y axis, it is ok.  if i go up on the y axis, the motors reverse themselves.  the x axis only goes left??

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Need help - Machine going nutz!!
« Reply #6 on: January 13, 2013, 01:31:29 PM »
Attach your xml and I will see if I can find the problem.
Hood
Re: Need help - Machine going nutz!!
« Reply #7 on: January 13, 2013, 01:37:25 PM »
here ya go

thx!!

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Need help - Machine going nutz!!
« Reply #8 on: January 13, 2013, 02:00:22 PM »
Dont see anything wrong in the xml that would suggest it wont work.
If you have a scope check the outputs, if you dont then you can still check the Dir pin outputs if you have a volt meter.
To do that change the E-Stop setting to Active Low and then remove the port cable from the computer an make sure Mach is out of Reset (not flashing) Connect the meter between pin 25 and  3 and jog Y one way then the other. Volts should change between 5v and 0v. Next connect to pin 5 and 25 and again jog Y and see if its the same.
.
Hood
Re: Need help - Machine going nutz!!
« Reply #9 on: January 13, 2013, 03:14:06 PM »
it is a constant 4.94 v