Hello Guest it is December 06, 2019, 06:03:00 PM

Author Topic: Problems with gcode exported to MAch from pcb-gcode...  (Read 2683 times)

0 Members and 1 Guest are viewing this topic.

Problems with gcode exported to MAch from pcb-gcode...
« on: December 18, 2012, 08:30:29 PM »
I am fairly familiar now with Mach3, have run a  few parts.  Next I need to engrave some printed circuit boards.
Got to the point where I can run the pcb-gcode add-on in Cadsoft Eagle, and have respectable gcode, and a decent looking board file.
But the gcode despite being told to be MAch3 compatible in the setup, won't run...it stops early on, at M3 code, and if I skip it, it finds more incompatible gcode errors.....am I missing something?   some of the code follows...

(.../EAGLE-6.3.0/ulp/PCB-GCODE/pcb-gcode.ulp)
(Copyright 2005 - 2009 by John Johnson)
(See readme.txt for licensing terms.)
(This file generated from the board:)
(.../fuel flow large enclosure.brd)
(Current profile is .../ulp/PCB-GCODE/profiles/mach.pp  )
(This file generated 12/18/2012 2:58:16 PM)
(Settings from pcb-machine.h)
(  Tool Size)
(0.0070  )
(Z Axis Settings)
(  High     Up        Down     Drill)
(0.5000     0.1000     -0.0070    -0.0320 )
(spindle on time = 1.0000)
(milling depth = -0.0100)
(text depth = -0.0050)
(tool change at 0.0000  0.0000  5.0000  )
(feed rate xy = F20    )
(feed rate z  = F10    )
(Settings from pcb-defaults.h)
(Default isolate = 0.0010)
(isolate max = 0.0200)
(isolate step = 0.0050)
(Generated top outlines, top drill, bottom outlines, )
(Unit of measure: inch)
(Inch Mode)
G20
(Absolute Coordinates)
G90
G00 X0.0000  Y0.0000  
M3  
G04 P1.000000
G00 Z0.1000  
G00 X1.4277  Y1.7565  
G01 Z-0.0070 F10    
G01 X1.4277  Y1.7639  F20    
G01 X1.4262  Y1.7712  

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Problems with gcode exported to MAch from pcb-gcode...
« Reply #1 on: December 19, 2012, 03:19:49 AM »
Can you attach the whole of the code, what you have pasted in is fine. Also if you attach your xml I will check with it.
Hood

Offline Tweakie.CNC

*
  • *
  •  8,012 8,012
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Problems with gcode exported to MAch from pcb-gcode...
« Reply #2 on: December 19, 2012, 06:22:01 AM »
As Hood has said.

May be best to Zip your code (assuming it is lengthy) and add it as an attachment in addition to your .xml file.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Problems with gcode exported to MAch from pcb-gcode...
« Reply #3 on: December 19, 2012, 08:15:28 AM »
Hmm....I am testing that code on my office machine, virtually in Mach3.  Maybe it's just hanging up for some silly reason there, and will cut fine on the system.  Lemme see. Thanks