Hello Guest it is June 02, 2023, 08:36:15 AM

Author Topic: pokeys 56u analog FeedRate Override issues  (Read 17081 times)

0 Members and 1 Guest are viewing this topic.

Offline tantan

*
  •  125 125
    • View Profile
pokeys 56u analog FeedRate Override issues
« on: December 08, 2012, 08:55:43 AM »
hi,

i use the latest mach and pokeys software.
if i map encoder 1 directly to FRO (DRO:821) it works great, but it would be perfect if i press reset FRO that the encodervalue would be reset too to a value of 100.
if i use analog input on input 41-47 and if i map this to DRO:821, feedrate override does not respond correctly, or not respond at all.

tnx TanTan

Offline NeoTO

*
  •  504 504
    • View Profile
    • PoLabs
Re: pokeys 56u analog FeedRate Override issues
« Reply #1 on: December 10, 2012, 02:12:35 PM »
Hi, TanTan

Regarding the reset - we will take a look whether we can find a proper solution to this.

Regarding the analog mapping - did you have both the encoder and analog inputs mapped to the same DRO?

Regards,
Matevž
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope

Offline tantan

*
  •  125 125
    • View Profile
Re: pokeys 56u analog FeedRate Override issues
« Reply #2 on: December 11, 2012, 02:25:23 AM »
Hi,

Tnx for looking to reset the encodervalue with the mach reset fro button.

No i did not use the dro twice, first i tested it with the analog on port 41 and then on port 43, no result. I can see the analog values change in the pokeys plugin but the mapping from the pokeysvalue to the mach dro does not work.

The same results for speed override

Thanks

Tantan
Re: pokeys 56u analog FeedRate Override issues
« Reply #3 on: February 08, 2013, 12:03:15 AM »
This has been my issue of late... mapping a potentiometer on one of the analog inputs of the Pokeys 56U to control FRO and spindle in MACH3.
MPG (on encoder #1 ins) moves the FRO (not very well...12 bit not 10 bit like the 55 so the numbers/ratios are all wrong) but not the analogs.

On the 55 there are comments all over this board regarding mapping to the G100 modbuss 124-127

But on the Pokeys 56U there are more analog out ports... starting at a lower pin number.

So...WHAT is the proper mapping of the analog outs of the 56U to the ports as compared to the G100 124-127 registers comments and brains examples here.??
What is MACH3 looking at to see the analog ports of the Pokeys 56U??   

The analog outs are all visible (and functionally changing) with the plugin config screens.
But the mapping is simply not controlling the FRO or spindle controls in MACH3

Can someone layout in one place, the complete info to do this mapping with the latest Pokeys 56U (and its latest plugin) and the latest version of MACH3
thanks to all of you, for all the help thus far and the fantastic resources supporting this software platform.

Paul Tegler

Offline tantan

*
  •  125 125
    • View Profile
Re: pokeys 56u analog FeedRate Override issues
« Reply #4 on: February 08, 2013, 09:20:35 AM »
hi, i think this is the way to use feedrate and speed override (see movie). not with resitors but with encoders.

http://www.youtube.com/watch?v=4QKVMtbvAC8&list=UUlJ5PqKDAvxW8vGTMCioMtw&index=2
Re: pokeys 56u analog FeedRate Override issues
« Reply #5 on: February 08, 2013, 08:58:35 PM »
...have seen that video before.... doesn't tell me anything in response to the Q I posted above.
resistors?  I'm trying to use a potentiometer control spindle speed and Feed rate override.
The MPG works just fine for jogging on the pokey 56u.
The analog changes are being seen by the pokeys Mach3 plugin configuration screen, but not MACH3 itself

I need info on what the mapping should actually be to get the analog signals to be recognized past the plugin by mach itself.

HELP!

Offline tantan

*
  •  125 125
    • View Profile
Re: pokeys 56u analog FeedRate Override issues
« Reply #6 on: February 09, 2013, 02:25:08 AM »
that is just what i try to tell you with my video, don't use potentiometers to control feed and speed override: use encoders (mpg). i used low cost encoders (4 $) for feed and speed override. for the rest is follow the manual.

Offline poppabear

*
  • *
  •  2,235 2,235
  • Briceville, TN, USA
    • View Profile
Re: pokeys 56u analog FeedRate Override issues
« Reply #7 on: February 11, 2013, 08:01:19 AM »
I think I will step in here, since a user or two has messaged me about this.
Understand that Matt is the lead bull on this, but what your seeing at least on your
"Mach not seeing the spindle speed OVR", is a MACH3 issue that you have to change one of its parameters.

When you want to do and "External" Spindle speed override that comes in across the "Mod Bus" registers.
then you have to put the following code in your "Init" Script so it runs at start up.

SetParam( "RPMOverRide" , 1 ) ' allows external override of dro 39 then you can use a brain to terminate to DRO #39

Feed Speed OVR should be working IF, Matt is still mapping the analog values to the "Old Style" serial Modbus registers listed in the above threads.

NOTE: Matt does NOT have to use those registers, he could map them just as easily to the newer Plugin supported serial, or even TCP modbus registers.
Or for that matter, to a user definable UDRO, that the user picks from one of his config screens.

Brains: The main purpose of Brains was so that users could map, the I/O to/from all of the Modbus types: Serial, Serial plugin, TCP, and test.
PLEASE see "Brians Users Guide" that I wrote in the member doc section for more details on this.

Understand also, that you do not actually connect to the PoKeys via the "Modbus" sub-ap, UNLESS you are using the Pokeys native Modbus calls.
The Analogs can (or used to be when I was doing the plugin), mapped to the old school modbus registers that where the second input row on the old style
modbus config page.  Your not necessarily using "Modbus", even though you can see the results in the modbus test dialog, since it is just reading the registers,
under discussion, since that is where that info is mapped to. 

Scott









fun times
Re: pokeys 56u analog FeedRate Override issues
« Reply #8 on: February 11, 2013, 04:51:08 PM »
thanks much Scott... makes a bit more sense.
I'll let you know how it goes.

ptegler
Re: pokeys 56u analog FeedRate Override issues
« Reply #9 on: March 09, 2013, 09:37:32 PM »
Scott, tantan....
    I swapped to digital encoders by your suggestion Tantan.....
I can get the FRO to change no problem. My small encoders have a pushbutton under the knob...so I wired and programmed the push of the knob to do the reset function.
After almost being happy....no brain.....  I went to run gcode and noticed my steppers would not move at all?
????  what the ..,,,,,?
I just happened to touch my FRO knob and a motor moved very slowly. man oh man.... turning up my encoder...the motors start moving .
Seems the encoder mapping I config'ed in was totally taking over feed rate irrespective of any gcode command.
So that  attempt is dead.

What I'm having issues with is trying to figure out a brain that reads the encoders properly on the pokeys 56. I really need someone to define what MACh3 is expecting to see to read the encoders ???