Hello Guest it is October 19, 2019, 11:52:45 AM

Author Topic: USB Smooth Stepper with C25 Card problems.  (Read 9521 times)

0 Members and 1 Guest are viewing this topic.

USB Smooth Stepper with C25 Card problems.
« on: November 24, 2012, 03:06:11 PM »
Good afternoon all,
I've been lurking on this forum the last few weeks while I've been building my machine, and have learned a lot. So far I've been able to solve all my problems by reading thru the posts on the forum. My machine's working fine, I've routed out a bunch of test pieces and gotten the bugs worked out. My last problem I need a little help with. As stated in the heading, I'm using a USB Smooth Stepper with the plugin C25 card from CNC4PC. The problem I'm having is I have no voltage on the input pins of the C25 card. I have plugged the jumpers on the Smooth Stepper to supply +5 volts to the C25, and have that voltage on the +5 volt pins. I have ground on the Gnd pins. As a consequence  I have to use 5 volts out to the limit switches and back to the input pins. This works fine, except for my auto tool zero touch plate. If I don't isolate the router from all sources of machine/electrical ground, I crash my computers USB port when the touch plate connects with the tool bit. I borrowed the power supply from an old desktop computer I had laying around and used it to supply external power to the Smooth Stepper, and that at least stopped the crashing. I still occasionally get a bit of noise induced upon the tool touch that brings in false limit warnings, but that's not much of a problem. The C25 documentation shows that I should be able to use ground to an input pin, but as I said, I can't. No amount of Mach3 re-configuration changes that. If I unplug the C25 board and go straight to the Smooth Stepper printer port pins, everything works as it should, but or course I loose the isolation that the C25 board supplies.
So my question, is anyone else using this configuration, and can they use ground to trigger their input pins? I have filed a trouble ticket with CNC4PC, but have heard nothing back from them so far.

Thanks, Steve.
Re: USB Smooth Stepper with C25 Card problems.
« Reply #1 on: November 30, 2012, 05:53:42 PM »
Thought I'd add a followup. I finally got CNC4PC to give me some support. Their online support ticket feature doesn't always tell them they have a ticket. Seems like they should either disable it or check once in a while for tickets. Their documentation on the C25 board is wrong. The board only accepts 5 volts on the input pins. Grounds won't work. Hopefully they will update their documentation. So the board is nice in that it plugs right into the Smooth Stepper board, but it's not very versatile as far as input.
So what BOB's are others using with their Smooth Steppers? I'm thinking about junking the C25 BOB and going with something a little more versatile.

Steve
« Last Edit: November 30, 2012, 05:57:29 PM by WyoWood »

Offline mc

*
  •  381 381
    • View Profile
Re: USB Smooth Stepper with C25 Card problems.
« Reply #2 on: December 02, 2012, 02:44:08 PM »
I've got the misfortune of owning a C23, and I've got no plans to buy anything ever again from CNC4PC, after the troubles I had with it, which was eventually traced to a missing socket in one of the opto sockets.

If you want to use a SS, I'd personally buy something from PMDX, as I've yet to see anybody who's had any non self inflicted problems with them, and having spoke to people who've had both, they all say PMDX are better quality.
Re: USB Smooth Stepper with C25 Card problems.
« Reply #3 on: December 11, 2012, 06:11:50 PM »
I ended up junking the C25 board and replaced it with a PMDX-126 BOB. The 126 is doing everything I want, the way I want it done. Much happier with it than the C25. Should have went with it to start, but was trying to keep the cost down. Oh well, such is life.

Steve
Re: USB Smooth Stepper with C25 Card problems.
« Reply #4 on: March 12, 2013, 09:19:40 PM »
Hello. I was having the same issues with the C25. The documentation is wrong on several aspects. I have been experimenting with the board and believe I have figured out how to set up e-stop, limits, and home  switches for a 3 axis machine running Mach 3. Soon I will document what I have figured out and post something.