Hello Guest it is July 11, 2020, 04:36:33 PM

Author Topic: Mach3 changing settings  (Read 2281 times)

0 Members and 1 Guest are viewing this topic.

Mach3 changing settings
« on: October 23, 2012, 03:26:14 PM »
Mach3 just started acting weird. I believe it is Mach3. When I hit cycle start, the Z goes up and doesn't stop until it hits the limits.

Also no matter what I try for jogging, when ever I jog left or right or up it goes to 130 and doesn't change.

Weird behaviour. Any ideas?

Thanks,

Bob

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 changing settings
« Reply #1 on: October 23, 2012, 03:28:33 PM »
Attach your xml and I will see if it can be replicated here.
Hood
Re: Mach3 changing settings
« Reply #2 on: October 23, 2012, 03:45:46 PM »
See attched xml.

Thanks
Re: Mach3 changing settings
« Reply #3 on: October 23, 2012, 03:55:56 PM »
I did try a backup of my xml from earlier when I know it wasn't doing it and it does the same thing.

In the GCODE when after I hit cycle start the line N120T1M06 the Z just goes up and hits the limit.
« Last Edit: October 23, 2012, 04:02:19 PM by bevins »
Re: Mach3 changing settings
« Reply #4 on: October 23, 2012, 04:45:19 PM »
can you post your m6start macro

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 changing settings
« Reply #5 on: October 24, 2012, 03:06:53 AM »
Ok seems fine here, I can jog as much as I want and the DROs keep counting so not sure whats wrong. Can you just clarify that that is what you were meaning when you said "Also no matter what I try for jogging, when ever I jog left or right or up it goes to 130 and doesn't change"

One thing I did see is you have your home and limit switches all connected to pin 10 but the active states for them are different, dont think that can be right.
Hood