Hello Guest it is June 02, 2020, 03:42:29 PM

Author Topic: feddrate  (Read 4012 times)

0 Members and 1 Guest are viewing this topic.

Offline PCH

*
  •  63 63
    • View Profile
feddrate
« on: October 02, 2012, 02:50:06 PM »
My g code is generating a specific feedrate but is not running at that rate.  The dro is showing a slower rate.
What's wrong?   :(

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: feddrate
« Reply #1 on: October 02, 2012, 02:58:33 PM »
What are your feed rate over ride and rapid over ride dros set to?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline PCH

*
  •  63 63
    • View Profile
Re: feddrate
« Reply #2 on: October 02, 2012, 03:11:27 PM »
Feedrate or set to 100
Where is the rapid or?
FRO %  100
FRO is 100
Feedrate 100

Offline PCH

*
  •  63 63
    • View Profile
Re: feddrate
« Reply #3 on: October 02, 2012, 03:36:12 PM »
Bobcad is putting feedrate at the last ramping pass on a circle cuttout.
Not matter what I do I cannot edit the gcode to change it.  Something about
the path not being right.  Can't feedrate override for somereason. 
Also I can not edit it in Mach.  It will not save for the same reason about a path.

Help!

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: feddrate
« Reply #4 on: October 03, 2012, 07:09:43 AM »
FRO may be inhibited via the code, have a look and see if there is a M49 in the code.
Hood

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: feddrate
« Reply #5 on: October 03, 2012, 07:11:38 AM »
Oh and as far as editing, sounds like Mach cant find notepad, you can tell Mach where to look from General Config page and using the browse option, normal path is \Windows\Notepad.exe

Hood

Offline PCH

*
  •  63 63
    • View Profile
Re: feddrate
« Reply #6 on: October 03, 2012, 07:40:23 AM »
Hood,

No M49 in code.
My path is correct in the Gen Config.
I am networking with my office pc and it "cannot find path" which
is the path to the office pc.  Maybe that's the problem. 
When I chose "edit code" in Mach it does take me to notepad but
when I make changes it will not save and I get the message "cannot find path"

Suggestions?

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: feddrate
« Reply #7 on: October 03, 2012, 08:05:09 AM »
Attach your code and xml and I will look when I get back form the DR.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: feddrate
« Reply #8 on: October 03, 2012, 08:40:19 AM »
That is not recommended, copy the file to the machines hard drive before you run from Mach.
Hood

Offline PCH

*
  •  63 63
    • View Profile
Re: feddrate
« Reply #9 on: October 03, 2012, 12:40:28 PM »
Hood,

Not sure how to go about that.
But I have a bigger issue.
Something Bobcad tech support cannot do for me.
I cannot enter 2 different feed rates.  One for plunge and one for feed.
On a circular ramp cutout it will run most of the code at the plunge feed
rate which is much slower that I want the cutting feed.  At the end of the
code on the final pass it jumps to the feedrate that I entered for cutting feedrate.
And ideas?
Attached is file that shows the 20ipm that I have setup for plunge but it is also
running at that speed for the cutting until the end.

Help ???