Hello Guest it is January 18, 2020, 05:29:57 PM

Author Topic: Table work area question  (Read 3054 times)

0 Members and 1 Guest are viewing this topic.

Offline Coils

*
  •  15 15
    • View Profile
Table work area question
« on: September 29, 2012, 03:08:57 AM »
OK I'm a complete newb so be gentle and don't get to tecnical, I'm still trying to figure this stuff out.

I watch the video on "homing & limits" a couple times and can't figure one part out.
When I load the Road Runner (RR) g-code it's always bigger then what I have set for the table size, when you click on the "display mode" button and it shows the out line of the table and the RR is always hanging over the distance for the Y. Yes I'm hitting the "Regen Toolpath button. Oh my table is roughly 8" x 22"

But what's confusing me is in the video he is showing a table of 100mm x 100mm and the RR is really small in the corner (or where ever he places it). The only way I can keep it within my soft limits is to change my table size in one of the config screens to something like 7" x 12" but even then it fills almost all of the vertiual table top.
So how can you change the size of the RR g-code to make it whatever size I want?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Table work area question
« Reply #1 on: September 29, 2012, 03:26:57 AM »
The RR code does not have a definition of units in it so it will be seen as whatever you have your native units set to.
If you put a G20 at the start of the code it will be seen as inch or if you put a G21 it will be seen as mm.
The only way to change the actual size (apart from previous method) is to use the scaling at the side of each axis.
I just looked at the road runner and its size is roughly 6.3 x 7.7 units so either inch or mm depending on mode you are set in.
Hood

Offline Coils

*
  •  15 15
    • View Profile
Re: Table work area question
« Reply #2 on: September 29, 2012, 01:08:01 PM »
Ok I understand most of your reply, I'll try the scaling thing next and see what happens.
Thanks

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Table work area question
« Reply #3 on: September 29, 2012, 01:43:45 PM »
You should not have to scale it if you have Mach set up correctly if your table is as big as you have said.
Attach your xml and I will look.
Hood

Offline Coils

*
  •  15 15
    • View Profile
Re: Table work area question
« Reply #4 on: October 01, 2012, 05:00:18 AM »
I thought about the sizes you mentioned earlier today and was thinking the same thing, so I have no idea right now what's going on with that part of it.
I did try changing the "scale" next to the X & Y DRO from 1.0 to .750 and it worked like that. Still going to mess with it more though to see if I can figure it out.


I was going to get the xml, or try to, but the pc I'm using for this isn't on my network right now and I misplaced my flash drive, but I'll still get it.

Offline Coils

*
  •  15 15
    • View Profile
Re: Table work area question
« Reply #5 on: October 05, 2012, 09:06:14 PM »
OK to show how much of a newb I am (or is it noob this time), where is the xml? I went into the Mach3 folder and don't see one, all I see is another folder "xml backup" or "backup xml", if this is where I get it from do I get the one with the largest number after it for the most recent?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Table work area question
« Reply #6 on: October 06, 2012, 01:37:44 PM »
It will be in the main Mach folder, not the backup.
Hood

Offline Coils

*
  •  15 15
    • View Profile
Re: Table work area question
« Reply #7 on: October 06, 2012, 07:57:10 PM »
OK I think I found it, lets see if I can attach it now

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Table work area question
« Reply #8 on: October 07, 2012, 02:49:25 AM »
Looks fine here with your xml and no need to scale.
Hood

Offline Coils

*
  •  15 15
    • View Profile
Re: Table work area question
« Reply #9 on: October 07, 2012, 04:17:42 AM »
I'm assuming you got the pic by using my xml?
And that doesn't make sence to me, when I have the scale at 1.0 either the head or feet hang over the display table limits a little, when I put it to .750 it's a little smaller then in the pic.  Well I'm not going to beat my haed against the wall over this, and will look over my settings in the "config/homing & limits" some more to make sure.

Thanks for all your help, and I do feel better that someone else says it looks ok  : )