Hello Guest it is November 15, 2019, 05:59:13 AM

Author Topic: z-axis will not back off home switch  (Read 5416 times)

0 Members and 1 Guest are viewing this topic.

Offline aahka

*
  •  15 15
    • View Profile
z-axis will not back off home switch
« on: July 13, 2012, 11:29:56 AM »
We have received & installed all of the physical equipment on our Joe's R&P CNC Router and have everything working with one exception. All of the limit switches (five of them-X,Y & Z Home, x++ & y++,no z++ switch) are hooked up in series and three of them also duplicate home switches. I'm using Mach3. I cannot get the system to home. The z axis closes the limit switch at the top (also the z axis home) but will not back off the switch. I have read the instructions thoroughly and have tried every variation I can think of to no avail. The homing & limit pins are set, home neg is not enabled and auto zero is. Slow zone is set to .125" & I’ve varied “home off” from .125 to 2, both positive & negative. None of this works. Can someone give me or direct me to help on this item. I think I'm ready to go when this is solved. I’m very new at CNC work and also at using forms.  This, in fact, is my first attempted  post, so please excuse any errors.  I will try to attach my .xml file.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: z-axis will not back off home switch
« Reply #1 on: July 13, 2012, 01:58:45 PM »
Does the LED at the side of the Z Axis DRO stay red or turn green?
You say you have them all in series, is that all switches in series or just each axis in series?
In your xml you only have Home switches set for each axis, you do not have limits set. The homes are all on separate pins so that is why I queried the "in series" bit.
Hood

Offline aahka

*
  •  15 15
    • View Profile
Re: z-axis will not back off home switch
« Reply #2 on: July 14, 2012, 10:10:12 AM »
Thanks for the response. I believe the DRO stayed red.  The machine is at my shop and I probably won’t get back to it again till Monday.  The single wire series includes all five switches and are connected to a Gecko 540 controller at Terminal 1(DP25 pin 10) & ground at the power supply ground V-. Initially I was going to run the limit switches for each axis to separate pins.  I’ll need to reset the home switches and add the pin 10 selection to the limit switches as well. However, I wouldn’t think that would affect homing since the carriage is supposed to trip & reset each homing switch in sequence z,x,y during the homing process (I think).  Is there a way to set the home machine coordinates through the computer keyboard?  It seems that I only need to set machine home once and that I will probably operate thereafter off of Fixtures 1(G54),2(G55),3(G56)…(Work offsets) or reset work offsets for each job from the Offsets (Alt-5) Menu (again I think). Again, thanks for your help.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: z-axis will not back off home switch
« Reply #3 on: July 14, 2012, 10:14:24 AM »
You have the home switches set to different pins, (X10,  Y11, Z12) if they are all connected in series to pin 10 then you need to set them all as pin10.
Hood

Offline aahka

*
  •  15 15
    • View Profile
Re: z-axis will not back off home switch
« Reply #4 on: July 16, 2012, 11:39:26 AM »
I reset all of the home  ports to 1 and pins to 10.  Then I tried to REF ALL HOME and I ended up with the same result - z moves up til it hits the limit switch but continues to push through the switch after it is closed and does not attempt to back offf the switch and set the Z home.  I am still using the Demo download. I intend to by the full license as soon as I'm sure Mach3 will work on my machine.
Is there any alternative method of setting the home values than closing on the home switches? The Zero X, Zero Y and zero Z have beeen RED bordered from the first time I loaded Mach3Mill.  I never had a green line next to any of these boxes they way it shows in the tutorials.
I appreciate your patience with all this. I feel sure that I'm probably missing something very basic. I've tried changing values every way I can think of but can't seem to set Home. I think I have read every tutorial & watched the tutorial videos over five times each and don't seem to be able to find the key.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: z-axis will not back off home switch
« Reply #5 on: July 16, 2012, 01:41:36 PM »
It should work if Mach is seeing the home switch input, to test go to Diagnostics page and press the switch by hand and see if the m1, 2 and 3 Home LEDs light up. If they are already lit and go out when you press the switch then you have the active state set the wrong way. If they do not light up then you either have them wired wrong or have them set up incorrectly.
Hood

Offline aahka

*
  •  15 15
    • View Profile
Re: z-axis will not back off home switch
« Reply #6 on: July 20, 2012, 06:54:23 AM »
Finally got them set up & working correctly.  Thanks for your help. I'm going to sign up for a license today & try cutting items.